Error in run time and continuing the process between flowcharts

Good Evening All,

I am having an issue with a process between sequences and flowcharts. I can’t get the bot to continue to the next flowchart. I ran the bot over an hour and a half as well as debugging it.

Any information would be greatly appreciated. Thank you

Main.xaml (339.7 KB)

You are not getting any error right? I hope you have an infinite loop inside the code. please check in debug mode where it is looping continuously @Sugaray

Please set the debug points at different places in your workflow and check at which debug point it is taking longer time.

If you think your workflow actually takes less time to complete and then debug and see where exactly it is failing.

Karthik Byggari

I believe it’s looping continuously in the steps I put in the picture above. I am not getting any errors. How do I stop the loop so it can go to the next step?

Please check why it is looping continuously @Sugaray. If it is how the process is designed, then you can check if all the transactions are done, then use break loop inside the loop and then it will move to next activity

Sorry, i’m still a rookie in creating process. what would I need to put in the place of Item and VB expression for the activity for each so I can use the break activity in it?

I hope your workflow is already looping continuously. You need to identify which loop it is looping (may your workflow will already have that loop statements inside). You don’t need to use the new for each,

Good Evening @HareeshMR ,
I ran the bot and debugged it for 4 hours. It looped around the last set of assign activities which is in the first picture I sent in the above messages. The row count is a little over 15,000 however after 4 hours of debugging, it continue to do the loop and then the count went up to over 17,000 rows which it isn’t true.
How can I resolve this issue? I’m still a rookie in RPA and I’m not sure which activity to use and where to place it.

I hope you are reading the data table and doing something and then using the write cell activity to write some data in the excel and again reading that excel right? The process goes on.

Can you attach the workflow please so that I will check with that once @Sugaray?

Everything is writing to the output excel correctly but it won’t stop creating data points even after reading the last row. Thank you for your help.

As per my understanding, the values you are assigning in the last sequence is making the loop infinite, check the each count value once using write line and find what is the issue?

And one more thing, you are processing multiple files in the workflow and using the same data table in each sequence. So, may be it is looping through that all the time. make sure it is not the issue