Error HRESULT E_FAIL has been returned from a call to a COM component on click event

Hi all!
I am trying to automate a time logging web application called Epicor. However, whenever i use click to indicate the “Search” field. It throws me the “Error HRESULT E_FAIL has been returned from a call to a COM component” error.
Following similar forums, I have tried many workarounds like clearing the cache, installing visual studio, uninstalling and re-installing uipath, uninstalling dot net framework and so on.
However I keep getting the same error.
I tried using ui explorer, but i get the error “UI element is no longer valid”
Also tried web scraping, get text , find element etc. activities but to no avail.
There are a lot of similar topics, but none seem to help me…
Please help me with this error.

Hi @kaivalya03 - Try the click activity by checking “Simulate Click” or “Send Windows Message” any one of it in the Property Window of Click.

If not try to use Element Exist of “Search” inside the Retry Scope and then perform the click if element exists in True

Or else you try use click image activity for “Search”

Thanks,
AK

Hi @AnandKumar26, thank you for your swift response !
As suggested I tried all the 3 methods: my results were
Simulate click / Send windows message - HRESULT error
Element exists method inside retry scope - HRESULT error
Click image for “Search” - An error saying “Image must be set”
So basically I am not able to get the selector for this “Search”

Hi, Did you indicate the element on screen. When will you get that “Search”? Will you get that Manually. If so then you can able to scrap the “Search” that will give you the selector.

Regards,
AK

@AnandKumar26, yes, I indicated the element on screen, but it gives me the same HRESULT error.

How about the image on screen. Give “F2” and that will give you sometime to spy the image.

Regards,
AK

It is not able to capture the image successfully, gives me the error “Image not set”

The screen shot you have shared right that has the image of “Search” take it from there. BOT will search for that image only.

Regards,
AK

Did exactly according to what you said, it gives me error “Image must be set”b22e05e1ae9574026919a5179bb25134ebad3de0_2_690x387

Please see attached screen shot. I am able spy the image “Search” using Click Image Activity

SearchImage

Regards,
AK