Exception :: Error HRESULT E_FAIL has been returned from a call to a COM component

activities
core_activities

#1

I have select Get full Text activity, then click on indicate the screen, when i am trying to select particular text or button, it will select full browser., when i am running this app, its throwing this exception.can some one plz help me to sort out this issue.
I’m attching screen shot also which show that its selecting whole browser instead of selecting particular text.

thanks


#2

If you are using the Chrome , having a chance to get this error.Can you try the internet explorer.

Thank you
Balamurugan.S


#3

First Use log and print the output of “Get Full Text activity” and check. Make sure you have the data and then you start your manipulations.
It seems you are trying to Trying the scrap the Blank Value. Empty Space sometime causes this issue


#4

Thanks for quick response.
I’m using IE browser, facing issue in IE


#5

Thanks for quick response.
I have store the value in a variable, in msg box, I printed that variable, sometimes it’s give value Microsoft edge or something it throws exception as mentioned above.


#6

Check the selector again . Try Attach with Live Element option


#7

Let me understand:
-can you select individual elements in a IE webpage with uiexplorer?
-what studio version are you using? What OS?
-this scenario did work at any time in the past?


#8

I’m not able to select individual element in UIexplorer.
studio version - studio version 2018.1.2 community edition
i’m just new to UIPATH, last 10 days i’m using this. This scenario have not work in past also.
here i’m attached sreenshot of UIexplorer.


#9

Can you start studio as Administrator?


#10

try with that also, still it gives the same error
Get Name : Error HRESULT E_FAIL has been returned from a call to a COM component.


#11

Hi,
I am also facing the same issue. I have tried the all above options, i still see the same error. Please let me know if anyone find the solution.


#12

I too get this exception using IE while trying to run activity that will find & click on a hyperlink.

Using UiPath Studio 2018.1.4 Enterprise Edition
on Win 10 Enterprise 64-bit

Re-booting and Also attempted above options did not resolve:

image

Workflow Exception !
mainFC-Link has thrown an exception

Source: Click ‘DIV claimstatus-to-cla…’

Message: Error HRESULT E_FAIL has been returned from a call to a COM component.

Exception Type: FindElementException

UiPath.Core.FindElementException: Error HRESULT E_FAIL has been returned from a call to a COM component. —> System.Runtime.InteropServices.COMException: Error HRESULT E_FAIL has been returned from a call to a COM component.
at UiPath.UiNodeClass.FindFirst(UiFindScope scope, String nodeID)
at UiPath.Core.UiElement.FindFirst(FindScope scope, Selector selector)
— End of inner exception stack trace —
at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)


#13

Is it the same with other browser? Is it the first time you get this error? Or was it running fine before?


#14

1st time running on IE, do not have option of using another browser in production
{ could try a test in Chrome but need this to work with IE }


#15

Glenn, can you try to find and click on another element?


#16

Even i am getting same error but i am using with PDF OCR activity. Please help


#17

I am also getting the same issue when we try to capture text box, Button Click or another elements, This problem occurs suddenly, to resolve i added Chrome Extension, .Net framework 4.5.2. but issue still remains
HRESULT%20E_FAIL%20error
whats the solution to resolve issue


#18

I am getting the same error as well. UiPath was able to identify elements earlier with chrome but now it is not detecting any of the elements. Please let me know the resolution.


#19

Hi, same here. Re-installing UiPath resolves the issue, however, it appears again after certain period (couple of days). Please help!!! :slight_smile:


#20

I experienced the same issue with the read csv method. I was able to resolve it by logging directly into Windows 10 and fixing a licensing problem with Excel. Prior to that I was using Parallel’s VM. Not sure if that is the right solution but in my case it worked.