Cannot point to the exact location of the element on the screen

browser
uiautomation
studio
extension

#1

Hi,

I was trying to identify elements on the screen using Indicate on screen but I am not able to point to the particular location of the element.

Initially I was getting an error “error hresult e_fail has been returned from a call to a com component” but after doing what’s mentioned in the below link, that error is gone. But apparently I can’t point to the exact location of the element and data extracted is incorrect.

http://www.codepartners.com/Blog/TabId/110/PostId/139/what-to-do-when-error-hresult-efail-returns-from-a-call-to-a-com-component.aspx

I have .net 4.7 framework installed on my machine and I’ve removed the other frameworks. I have uninstalled the other versions too. I have added the extentions to the chrome browser, the browser on which I am currently working. Is there anything else that I have to do?


#2

Try it on IE.


#3

Tried that as well and this is what I see


#4

Looking at the screenshot I think that’s Microsoft Edge not IE. :thinking:


#5

@ddpadil Sorry my bad. Works fine on IE. But there’s an issue with other browsers. Any idea on what the issue could be?


#6

@chaitu.santapur please check your extensions properly, if installed remove, re install and then try.


#7

@pathrudu I deleted the extension that were there, I removed them and I already added extension in Chrome from the scratch. It’s still the same. I am not sure if this is related but my chrome versions is up to date. Apparently it works with IE and Firefox and this certainly isn’t a showstopper but what could be the reason for this to happen only in Chrome but not in other browsers.


#8

Hello ,
UiPath prefer IE and it works best compare to other browser.
In case you didn’t try this out yet please see the steps.
Chrome Extension Troubleshooting


#9

Just installing the extension isn’t enough. Restart the browser and it should be fine