Error Execute Oracle Stored Procedure using refCursor parameter

Hi Everyone,
I have problem with execute query activity when trying to execute oracle SP. It keep returning

Execute Query: ORA-06550: line 1, column 7:
PLS-00201: identifier ‘PROC_NAME’ must be declared
ORA-06550: line 1, column 7:
PL/SQL: Statement ignored

I have checked it can run succesfully in db
I have checked user role that I use have authorization to run the SP
I can established connection to the db.
Command Type have been set to Stored Procedure
Sql have been tried with “PROC_NAME” and “dbo.PROC_NAME”
Parameter name have been set to the same name as in the SP, but data type set to normal String. Have been tried with and without out parameter. When out parameter tried, I’m using datatable as the data type.
Output DataTable have been set with empty datatable

The only possible problem that I can spot is in the parameter I’m using prcResult OUT sys_refcursor, but I can’t find the appropriate data type in UiPath.

I can’t put the query here as it’s quite sensitive data.

Any suggestion to solve this error?

1 Like

update:
ORA-06550: line 1, column 7:
PLS-00306: wrong number or types of arguments in call to ‘PROC_NAME’
ORA-06550: line 1, column 7:
PL/SQL: Statement ignored

After some change, I manage to succesfully call the correct format, but I still have difficulty with passing refCursor parameter into Execute Query parameter.

Please help…