How to execute PL/SQL Stored Procedure?

How to execute a stored procedure using PL/SQL in UiPath?. I have a database in Oracle Database Developer and tag in to a stored procedure to execute.

command type: storedProcedure
sql: "greetings "

here is a sample Procedure I’ve created:
dbms_output.put_line(‘Hello World!’);

below error using “EXEC greetings” and “greetings”

Hi @VicP ,

Nice to connecting with you again.

i hope the mentioned procedure working in SSMS.

Are you using Execution type as stored procedure in the Execute Query activity.

And also please remove the semicolon in the End statement and try executing it.

please refer the below links for your reference.


Hi @kirankumar.mahanthi1 , yes I’m using execute query activity. i’ve also tried removing semi colon it is throwing this error.
the stored procedure though workins fine in oracle sql developer

Execute Non Query: ERROR [42000] [Oracle][ODBC][Ora]ORA-00900: invalid SQL statement

This looks completely fine

There is an syntax error in statement

Did we try the same statement in a sql database server
Check there once for the error and pass the same here in uipath

As an alternative place the script in a txt file and use READ TEXT FILE activity and get the output as string named strinput

Now pass that variable with sql property

The reason is when you are passing the command as it is the single quotes May throw error


Hi @Palaniyappan thank you for helping me out.
the script above works perfectly fine in Oracle SQL Developer no error at all, however when it is executed in uiPath it throws some error. i also tried placing it into a text file and pass into a string variable using the execute query and non execute query activity but no luck.

I don’t find any error with the above statement
Try removing that forward slash at last and run it

May be let’s do one thing
Let’s create this procedure in your dB server
And call that procedure here in uipath using the database activity