Error detecting project version or Missing activities

Hi Team,

I have developed a code in latest community edition(2019.*) but we have used enterprise edition (2018.4.5) in production environment. I have opened the code which was developed in latest version of community edition into production version, getting issues like “Error detecting project version”.

As some of the users suggested I have tried the below options

  1. Delete the project.json file and opened the code again but didn’t work, getting “Missing or Invalid activity” issues and didn’t get the complete code.
  2. Created a new project in Enterprise edition and copied project xaml files except project.json file (from community edition to Enterprise edition) but still didn’t work. Able to open the file but getting same issues like “Missing or Invalid activity” issues and didn’t get the complete code.

We have already finish the complete coding in community edition and now we need to open/integrate the same in production version? Please suggest.

1 Like


You developed the process using lastest version of Community Edition and also as you said you are using Enterprise Edition 2018.4.5 and its old version.

The packages you installed in latest community version may be not be avilable in Old version and because of that you its not opening those activities and its giving that error.

If possible try to install latest verison of Enterprise Edition of UiPath studio i.e. 2019.10.0 and then try. It should work.

Kindly make sure that you have same version of project dependent packages
like the activities and its package version must be same and if so we wont face this
–for that in your previous projecet open Manage packages in studio in design tab and open PROJECT DEPENDENCIES and check the version
try to resemble the same version of package in your new process xaml

Cheers @katakam26

Thanks for your time guys.

Yes, I have understood but the situation is Production instance migration(from 2018 to 2019) will take some time. Due to some emergency we have developed some piece of code in Community latest edition. Now we are facing challenges to integrate these two.

Do we have any possibility to install the lower version of community edition which matches with enterprise edition? Else any other alternative to come out of this issue, Please suggest.

Hi @katakam26

I’ve had the same issue a couple of times, and the solution i’ve used is like this:

1 - create a copy of the project.json that works.
2 - copy the dependencies: to a new file Ex: “dependencies”: {
“Microsoft.Activities”: “[1.0.1]”, etc"
3 - delete the project.json and open the workflow w/ UiPath (it will still get erros b/c of the missing dependencies)
4 - Close UiPath
5 - Edit the new Project.json and add the Depedencies you copied from the original projec.json

You should have a new project.json w/ the new Studio Version and all the dependencies loaded. Depending on the configuration you have on the Dependencies configuration in UiPath it will try to use the oldest version and will work :slight_smile:

1 Like

Hi @katakam26

I hope this might be helpful to you .Please read this for your reference.

cheers :smiley:

Happy learning :smiley:

1 Like