Error: can not open application snippingtool - does not refer to an existing file

I can’t open snipping tool, I keep getting an error does not refer to an existing file.

image

When I try to browse for the snipping tool inside UI Path, I don’t see it. But when I browse it in Windows Explorer, I can find it there. Anyone faced this problem?

Other applications like Notepad, is working in UI Path. Please help.

HI @philip2

Kindly make sure your organization is not blocking your SnippingTool.

Thank you.

Hi Jobin,

I’m sure it’s not, because I can open it normally. Only when using the UI Path application, I get this error.

Hey.
Yes, you’re right. I also can’t launch this application from Studio.

It’s looks like it is the UiPath issue.
I tried invoke C# code under visual studio and I used the same code under UiPath Studio.
In VS everything works fine but in UiPath Studio I got the error.
So, maybe someone from UiPath staff can help ?

My sample C # code to open a snippingtool:

string snippingTool = @“C:\WINDOWS\system32\SnippingTool.exe”;
System.Diagnostics.Process.Start(snippingTool);

@philip2
As a workaround you can use win+r and type snippingtool.exe to launch the app.
image

Hi @philip2 @pikorpa @Jobin_Joy

I have done small research and able to open the snipping tool with the below path. wanted to share it with you all. thanks.

“C:\Windows\sysnative\SnippingTool.exe”

image

1 Like

@kirankumar.mahanthi1
I checked your solution but I have the same issue as before ¯_(ツ)_/¯
image
image

1 Like

Hi @pikorpa ,

I am not sure may be system related I guess. For me system 32 path mentioned above not working. But mentioned in my post working.

Could you try remove double quotes from the path you mentioned and try. Thanks.

1 Like

I confirm that works :slight_smile:
Great job @kirankumar.mahanthi1 :clap:

2 Likes

Thanks @pikorpa :grinning::+1:

Confirmed it’s working! Thanks Kirankumar! What would be the next action after that? The click from Application doesn’t work.

Hi @philip2 ,

Glad to know that the suggested path working for you. Not sure on your question. Could you share your requirement what you are trying to achieve with snipping tool. With screenshot our forum members could help you much better. Thanks.

Hi Kirankumar,

I don’t know how to make a selection using the snipping tool using Ui Path. Can you share how to do that?

Thanks!

Hi @philip2 ,

I have never tried taking screenshots from snipping tool via UiPath. instead of that we can take help of the take screenshot activity and indicate on screen activity to take the Region screenshots. Please refer the below thread it would help bit on your requirement. thanks.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.