Error: A foreground process is already running

Studio 2022.4.4 - 8/3/2022
Community License
Microsoft Windows 10 Home 64-bit

When I launch my RPA in Studio everything is normal but when I launch the same robot using assistant then I get the following error at the very beginning:

A foreground process is already running. Only one foreground process can run at a time.

at UiPath.Service.Job.StartAsync(IUserCredential credential)

After the error my RPA continues opening a Form and everything executes normally but at the end of the RPA I get a new error. So it looks like two RPA are running at the same time but I have no clue why and how that is possible.

Furthermore I use a “use Excel file” activity that opens a local Excel file but in Assistant the Excel file opened is not the same as the local one. Suddenly the Excel file is in folder: C:\Users\user.nuget\packages\RPAname\1.0.8.

One more thing - when in Studio I run I get 13 errors that look like:

Bad IL format. The format of the file ‘C:\Users\user.nuget\packages\uipath.cefsharpbundle.netcore\1.8.0\lib/net5.0-windows7.0/libGLESv2.dll’ is invalid.

When using windows-legacy I had no problems. Now making new RPA using windows I get a lot of strange behaviour.

Every time I run RPA in Studio it states “Compiling” that takes a long time before my RPA is launched. Frustrating that I have to wait for that every time. Not and issue earlier with windows-leagacy.

Double-check to install the robot in Service-Mode and before running the unattended job, make sure that you are logout (logoff) from the robot machine.

Then check this documentation for your Service-Mode robot: Background Process Automation

@raven Its error coming when already process is open. Close all processes and then open again

As suggested by @marian.platonov you have to install UiPath in service mode

Hello @raven

Are you using community edition or enterprise edition??


community edition

No other processes are running. Yes the error appears after I run the process in assistant. Using Studio there is no error with double process

The process is attended. I am clicking the process in Assistant and then I am getting the error that a process is already running. I have other processes that are running normal for more than 2 years now.

@raven as you confirmed no parallel foreground process is running at the same time. Can you trypublish it again and check it once.

If not working, plz try a sample workflow with some message box and check whether you are facing the same issue.


Tried publish again, tried deleting everything and republish - nothing worked.

I have other RPA running without any problems. Only this one keeps throwing the error when run in Assistant

Is there any parallel activity used??


No parallel used

I found the error but I have no clue how to avoid it. The error is in Assistant. When the RPA named “ZK uvid” is clicked in the right pane I get the error. When clicked in the left pane it runs normal. All other RPA are running normal! So only this one named “ZK uvid” gives the error.

Anybody have a clue how to solve this error?

Is this an error in Assistant? Can it be solved?

In order to run my RPA named “ZK Uvid” I had to install .NET. Is this maybe the thing that triggers the error in Assistant? Another cause I can think of is that my “ZK Uvid” is named “ZK_Uvid” in my folder tree - maybe that triggers the error?

I have tested Assistant on another PC and I am getting the same error. Adding to the problems with Assitant my short cuts get deleted all the time: Forgetting Keyboard Shortcuts

Can anybody please help because these errors makes Assistant useless!