Attended Robot does not start (process is already running)

Hi Community,

we are currently experiencing an issue where an attended robot won’t start running, because “a foreground process is already running (UiPath.Service.Job.d__47.MoveNext())”. The robot is not connected to Orchestrator and running a package that is installed locally on the machine. Also, this issue only occurs on one machine, we ran the process on different machines and did not get the same error.

The robot is started by the shell command, which is called by a VBA Script. The tasks of the robot are to gather data from the excel sheet and input this data into a web application. After doing so the robot will trigger another VBA Script which will then again trigger the next run of the robot to repeat the process for the next data set. Note that the first run is always working without any issues.

We already paused the VBA Script that calls the shell command after the first run and realized that the UiPath Executor process is still running after the robot is done. When killing this process manually by using the task manager, the second run of the robot would work without any issues.

Do you have any idea what causes this issue and how to solve it?

Thank you in advance!

Hi @jonaz
please refer below link

hope this might help you


I hope you have connected your machine with robot. if not try this.

1.Tenant->Manage Access->Select your account->Edit->Robot Setup->Run Foreground automation

provide the following


Win+R → TYPE whoami->copy the code and provide it in Domain/Username

Credential store

Orchestrator Database


Your windows password

Credential type

Windows credentials

Then click on save.

Inside the studio:

please follow the below steps:

1.Signout from studio and UIPath Assistant.
2.Now close studio
3.Now open the UiPath Assistant Navigate user Icon ->Preferences->Orchestrator settings->Sign in

this will automatically sign in both Studio and Assistant.

now publish the workflow



thank you for both of your answers. Unfortunately the attended robot is not connected to the Orchestrator and therefore the machine is not connected to the robot either. We are running the robot by calling the UiRobot.exe and the local stored nupkg file with the command shell. No Orchestrator involved whatsoever.

Do you have any idea on how to solve the issue without using the Orchestrator settings?

Kind regards


Attended bot only works with the UiPath Assistant. if you want your attended bot should run with in the machine just connect your machine to orchestrator before publishing. make sure you have connected the studio to the orchestrator and also assistant.

once you published to the orchestrator you may see the process name inside the assistant. you can run it from studio or assistant.



we finally solved the issue by simply updating UiPath Assistant and Studio to the newest version. Previously we were running a 2020.xx version. So far, we did not experience this problem again.

Thank you very much for help!

Kind regards

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.