Dynamic Selector can't find the item!

I just do not understand why is that happening ??? Check App State can see the item but click activity is not clicking on it. Selector sometimes work but sometimes does not work.

Everything looks okay :thinking:

What should i do ???

Note : I am trying to click “Kawasaki”


Can you give a default value “Kawasaki” and check if that is able to click?
Also, if this is dynamically not working then you may allow some delay and check

Hope this may help you


Make sure the value of in_StrBrand is exactly the same as what you’re trying to click, no extra spaces etc.


It is already given before!


As you passing that through argument, are you sure that the value is passed correctly?
Also can you share the actual selector of that Kawasaki you are testing


1 Like

When you run the process, is something else overwriting the default value? The default is only used by Studio when designating the selector. Aren’t you assigning a value to it somewhere else when the automation actually runs?

@170290064 Before click or check state print the value?
I suggest use minimum variable in selector, one or 2 is enough.
second Check spaces aside value.

1 Like



Here it is!

Every time its getting different values from the queue. Thats why i made it dynamic.

So you need to know what the value is the times it doesn’t work.

1 Like

@postwick Here i am getting the value in correct way.

  • in_strCategory = “Motosiklet”
  • in_strBrand = “Kawasaki”

Bulundu = It was found.
Tıklandı = It was clicked.

There is check app state activity before click activity and its working fine.

@170290064 now place this value “Kawasaki
Bulundu” in default and check selector and highlight it. If its not correct one then

Make a test workflow and get selector for specially Kawasaki Bulundu and check what is the difference.

Are you usig same selector in check up state and click activity?

Hi @170290064

Try with the selector management.
Check the strict selector and uncheck the fuzzy selector and image.

Hope it helps!!


Targetting method is only strict selector. Fuzzy and image selector are already unchecked.

Here you are passing the variable to many attribute, select the proper attribute and pass to that attribute only. If you will give like this it was confusion to take the selector by bot.

Could you please provide the selectors attribute with out passing the variables and give me the information. @170290064

Not sure but it might cause of that reason. :man_shrugging:

Getting same error time to time but it worked for now.

@170290064 put retry on this

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.