Downloaded CSV file gets corrupted

When I download a csv-file from a website, the result is a corrupt file. The last lines are repeated several times. I use “HTTP Request” to download and I have only specified Endpoint and Resource path. Do I need to do anything more?
The file is perfectly fine if shown in the browser (and I know that other systems are able to process it perfectly). Very annoying. Hope you have an idea what could be wrong.

Just to get a little more clarity, can you try downloading the same from browser and check once, do the same from postman and check. If you got the same file, then the file is same as you are getting in the UiPath as well. May be some filters applied in the browser file I guess :thinking:


Thank you! Yes downloading directly for a browser (tried several) works perfectly. Also, there are other systems like Google merchant that uses the same file and reports no problem whatsoever. It’s just when I download using UiPath that I get an invalid text-file.

How do you suggest I would download from Postman in order to verify? Haven’t used Postman before.

Postman is also a tool used to test rest API where you can use the same URL in postman and check if the file is downloaded perfectly.

I understand but I tried using cUrl instead and the file downloaded perfectly. I can use StartProcess and use Curl but it would have been simpler to use HTTP Request.

Oh, we have powershell activity as well instead of start process and opening command prompt. You can try that as well

Thank you. I know but this was simple enough. Hope the HTTP Request bug issue will be resolved.