[Download Issue] Generate Yearly Report - Advanced Level Assignment 3

Hi,

I’m currently attempting Assignment 3, and in one portion of the walkthrough(WT), they asked to save your folder via this method so it will redirect you to the folder you’ve configured in the Config Excel file. However, for me, the issue is that even after assigning the path value, the file still saves at the default ‘Download’ folder. Can anybody please assist?

I’m using Chrome as the browser.

WT:

Config File:

Process Sequence:

Check if ReportFilePath is a valid directory path, and where are you using it?

Hi Robert!

Sorry but could you elaborate on what you mean by valid? I’m following the walkthrough so I’m not too sure where to check!

The folder I want to save to is:
C:\Users\ *****\Documents\UiPath\GenerateYearlyReport\Performer\Data\Temp

But it is saving by default at:
C:\Users\ *****\Downloads

Well, simply use a write line activity, and see if it has a value like “C:\Users\ *****\Documents\UiPath\GenerateYearlyReport\Performer\Data\Temp” and this path must be type when you download the report, are you doing that?

Alright I’ll try checking first and will get back to you!

Hey!

Unfortunately, I don’t know why it isn’t printing anything out:

As you can see, by the exception, the ReportFilePath has been assigned with the values correctly, it just doesn’t save and I’m unsure how to go about this:

Do you have the folder Data\Temp created? and you see the path being typed into the input? Also, don’t type the text in into the edit on top, but on the File Name input at the bottom, near Save button, on top of the file type.

Yes I do, also I placed it at the file name at first but it still didn’t work, as according to the WT but it gives me the same exception.

I’ve used different approach in Assign activity, i’ve used Directory.GetCurrentDirectory to get the current directory and then just used String concatenation to make up my Download string that i’ve used later

Type

This is what you mean right?

But it’ll save in the download just like that with the default name that you see highlighted as well as the default folder in Downloads.

If you type the full path, it won’t, give it a try.

Hey @srdjan.suc!

Thank you for your suggestion! I’ll try it out now :blush:

Hi sorry, full path in the config file you mean?

No, i mean type your variable, ReportFilePath, where i indicated in the previous picture (since it’s already a full path).

Hi! @RobertD

This is what you mean right? The type into input is targeted at the File Name section of the window.

Yes.

Hi,

Yeah, that’s what I’m trying to tell you. It’s not working. As you can see from the exception, the file path is stored in ReportFilePath correctly when reading the CSV, but because before that it didn’t save under the assigned named and folder (saved as default name in the default folder, “Downloads”) it throws an exception.

Hi,
I guess you already have changed the settings in Chrome for downloading files to ask you where you want to save the file before download?

if not Chrome saves the file to the preset folder for download without asking :slight_smile:

Been looking at a similar issue Report saving in the wrong Folder
Leave the type into with default properties, and when it types, check if it writes the path correctly.