Report saving in the wrong Folder

Hey all,

I’m confused on why this is happening in assignment 2 - Generate Yearly Report. When the file saves, it is saving in Generate Yearly Report-Dispatcher-Data-Temp instead of Generate Yearly Report-Performer-Data-Temp. Therefore, when process goes to read the csv; I am getting the below error. I check all of the arguments and variables and they are done correctly.

Any ideas on why this is happening?

image

Hi,

Can you attach your workflow and let’s see what I can do.

Thanks!

hello @jonathan89
can you check once default value of filepath adn path that enter in save as dialog box
if you getting filepath from excel file you can check there also

Thanks

@sandeep13

I’m getting the path from the config excel file.

Buddy kindly check whether that file is present in that folder @jonathan89
or check with spelling or special character mentioned in the file path, is there any mismatch with original one…
you can also check with path exists activity where you can pass this path as input and if the path exists this activity will return us a boolean value…
Cheers @jonathan89

@jonathan89
can you check value of path is completed path of Excel file ??

@caduque
@sandeep13
@Palaniyappan
hey all, this is what in my Config file, and I have included my workflow below.

CreateYearlyReport.xaml (24.9 KB)

Hi @jonathan89,

Kindly check the path you have provided in your in_ReportsDownloadPath. If I’m not mistaken, that’s where you put the path. Can’t check the xaml file you have provided as I have a lower version of Studio.

Thanks!

Hey all, @caduque @sandeep13 @Palaniyappan

I figured it out. It kept saving to the default folder ‘Downloads’. I fixed the issue be doing a ‘Basic’ recording. However, I have another issue, and asking if you can help me out.

January File is saving as Report-TaxID-1, however, the Report File Path is set to read Report-TaxID-Year-Month, so therefore it is throws me the error below.

Did anyone else encounter this? If so, how did you fix it? I have tried to play with this, but removing Year and Month from the file path and putting Report-TaxID-1, but the problem is when February is downloading it is showing Report-TaxID-2.

image

2 Likes

hello @jonathan89

you are using months as integer like 1,2,3

1)use select Item activity target should be like that
<webctrl idx='1' parentid='searchForm' tag='SELECT' />

  1. month should be string array .value will be {“January”, “February”,“March”, “April”, “May”, “June”, “July”, “August”, “September”, “October”, “November”, “December”}

for reference
image

don’t forget to attach browser activity at top of the activity

I attached sample workfowSystem1_CreateYearlyReport.xaml (19.9 KB) go throug it

hope it helps

Thanks
Happy Automation

1 Like

@jonathan89
One more thing assign ReportFilePath brfore the save as dialog box activity so file save as name assign in Reportfile path

image

Thanks

2 Likes

@sandeep13
OK thanks. Will check this out and let you know.

1 Like

hey thanks for the help, but what item should I be selecting?

Little confuse on the screenshot I should be taking.

thanks

here item is a month name that get from months array and set item in dropdown of month at every iteration.
see screen shot

I already attached workflow please check it once

Thanks

1 Like