Doesn't identify table


#1

@ddpadil
There is a table in a web page, but UiPath doesn’t recognize it. So, I manually tried to save the data of the table step by step using data scraping, clicking first element, then second element and naming the column, and so on and so forth until all the columns were covered. But the problem is that when I used write CSV, no data is saved in the file. I have wasted my entire day, but I found no solution to it. Furthermore, sometimes it does get saved, but when I run it again, it doesn’t work. Please tell me how to do it


#2

Hi,
Write CSV need Datatable as input. Did you add scraped data to datatable else use write cell to pass individual scraped data.


#3

Yes, I added the scraped data to the data table and passed it as input to the write csv activity


#4

Do you have any idea why the table is not being identified?


#5

Hi,
Can you check is there any value in datatable by passing this in writeline
datatablename.Rows.Count.ToString()

else please attach workflow.


#6

datatablename.Rows.Count.ToString() is showing nothing on the output panel. I guess the table is not getting extracted. The workflow is very simple, there is a data scraping activity and a write line activity. Is the problem related to selectors or live element?


#7

Screen scraper doesn’t give you datatable only datat scraping will give .Its just an variable of out argument .
you need to use bulid new datatable and add the data rows else pass each output from the scraper to write cell activity.


#8

But i didn’t use screen scraping. I have used data scraping


#9

ok then try above approach as i mentioned.


#10

The problem is that no data is being retrieved from the table of the web page due to some unknown reason. So I can’t pass its output to build the data table.


#11

You mean to say not even screen scraping able to get the value from the site.


#12

It does, but its not accurate nor it takes up the null values.


#13

Any sample url?


#14

Hi @sanap, Can you try using 2 seconds delay before scrapping and after scrapping?
May be the robot is not getting enough time to scrape the complete data.
Any screenshot or reference URL will be helpful here.


#15

The table is SlickGrid one. Is it an issue?


#16

The delay didn’t help. The table which I want to scrap is a slickgrid. Is it why the data is not being scraped?


#17

The only thing i can say here without watching the source code and the sample webpage is to play with selectors and try. :slight_smile:


#18

The selector doesn’t vary, however the Extract Meta Data has a part which changes with every new login.
class='finch-grid finchgrid-1 slickgrid_319825 ui-widget’
The number written in bold changes.
How can I make this xml reliable for any change in this part?


#19

In case of dynamic selectors, you can use .
Example: class='finch-grid finchgrid-1 slickgrid

It will ignore all the text after that *.

Try this.


#20

Will wildcards work in Extract Meta Data property too?