Disconnecting Remote Desktop

rdp

#1

Hey Guys,

I have a workflow that needs to open SAP and collect some data such that it can be entered into a PDF form. I’m using the “Invoke Interactive Workflow” activity to start the workflow.

The issue is, we’re wanting the run it on a VM which we’re using RDP to connect to. Everything runs fine when we’re connected to the server. However, when we actually have this running in production we intend to not be connected. And this is where our issues are.

So, we have a lot of image clicks for navigating certain parts of the workflow. And they fail when we’ve disconnected RDP, likely due to the whole Session 0 thing.

How can we get our workflows to run correctly when we’ve disconnected RDP?

Thanks,
Alex


#2

Hi,
I’m not sure which edition of UIPath your using if its community then" Yes, It’s a limitation for Community Edition, however I think the error is actually ‘Access Denied’ or ‘Resource in Use’.
I am assuming @Alkaros has Trial Version? Do you have UiPath Robot installed as a Windows Service?

To avoid this you can:
start the workflow from Orchestrator (not possible with CE)
run it from the tray after setting login credentials

Please go though this. (article on Interactive Session Management)


#3

Thanks ddpadil.

We were already running it from the system tray, though it looks like we may have forgot to set the credentials.

It does seem to be working now but I’ll do some more testing :slight_smile: