Diferents comportements doing invoke a SAP script

I have diferents comportements invoke a SAP script.
When I run the the SCRIP alone it works. When I put the scrip in the processo, it does nothing.
I have this issue with scrips with arguments and without any argument.
Any idea?

Hi @PEDRO_NEGRAO_MATOS ,

could you specify what you mean by running the script alone?
How do you invoke it in the process and what do you mean by doing nothing? Do you get errors?

BR

Hi,
If I open a new project a run the scrip it works fine.
If I put the scrip in my project it runs and closes without errors. But don’t fill in any the fields.
>Invoke VBScript Executing
> Invoke VBScript Closed
Thank you

So by “running alone” you still mean invoking the script in UiPath, right?
Could you share a screenshot of the invoke and settings or a workflow with us?

BR

Yes.
If I run this with the Log in in SAP done manually, it works:

If I run the same script but in other process with other SAP activities the script doesnt do anything (but I dont get any error)
I put a messagebox before to ensure that my argument have the correct value

The execution logs
image

But in SAP nothing happened.

Any idea?

thank you