Did UiPath limit write cell activity to XLXS and .XLS?

excel

#1

I had a working code in which I could write cell at xlsm. Now, same code is giving me error “Write cell : A strongly-named assembly is required. (Exception from HRESULT: 0x80131044)”. I did my debugging to understand what went wrong, then realized this is not accepting xlsm type.

Why would you do that :frowning:


Error with write cell
#2

I had same problem with the latest Excel activities update. Same kind of problem with Read Range :confused: My workflow which has worked before didn’t work anymore.


#3

@MGDEL @jmati
Please state your Studio and Excel package versions.
@qateam ?


#4

Studio Version : - 2016.2.6274
Uipath Excel activity version - 2.0.6333.17728 (I guess this is what you were asking)


#5
Can you please check your studio have Excel Package Installed or Not ?


#6

hello jmati

please give me the test file and maybe the workflow too for your problem.


#7

hello MGDEL
what activity are you using? workbook or excel scope?


#8

Hi Gabriel. I was using write cell, under system -> file -> Workbook -> Write Cell.

Does it help? and yes I have Uipath.Excel.Activities. You can test this in you system, just try writing something in macro enabled workbook(xlsm) using write cell.


#9

as a workaround, if you have excel installed, try using excel scope activities, those work.
in the new excel package update we provided support for xls files. this, indirectly limited the functionality for xlsm files, we will investigate further to see if there is a solution for this problem.


#10

Thanks! I have excel installed, I used this activity pretty extensively in my code (I was creating report). I will find a workaround. Any idea, when will it be fixed?


#11

unfortunately i don`t have an answer now.
do you remember what version were you using when this activity worked? studio and package?


#12

Unfortunately No :(. I will check with colleauge who are using Uipath and see if it is working for them. Can I roll-back the new changes?


#13

with the previous package, this didnt worked either, just that you didnt see an error. this is why i`m curious what were you using when you say it was fine :slight_smile:


#14

Ha ha ha! I suppose, I didn’t update my excel activity for long time. Bad Idea I guess!


#15

I got mine fixed uninstalling the update. It was normal excel .xlsx file. And it still works now using the older version (1.2.6256.15131).


#16

how do you uninstall particular upgrade?


#17

that`s a temporary workaround, in need more details in order to test it myself.


#18

When are we expecting fix for this? its causing us lot of trouble.