Desktop application Selector not appearing

Hi,
I am trying an action to find a value say order number from a table in a desktop application and just to start with, it does not return any selectors instead it selects a portion of screen. None of the methods like screen recording, data scrapping or ui explorer works. is there any option i need to try, i am not sure what is the technology used to build the application.
Please find below a screenshot.

Hi @robinsonjoseph

Is it a java application?

If yes
Then use java extension and try it

Nope it’s not a Java application…looks like a .net or c#…

Hi @robinsonjoseph

May I know the name of this application?
Also mention whether this is a new application or a old one created many years ago…

There are couple of options you could try…

In the UI Explorer, you can try using other UI frameworks if the default one is not working. This way you can see whether you can build a selector easily…

Note: selectors created in each framework will be different.

If that doesn’t work, next option is to see whether you can interact with the application using hot keys

If that is also not working,
Try computer vision activities

Hi @robinsonjoseph
Is this application is on VM or on your system?

Hey @Lahiru.Fernando thanks for the suggestions… this is an ERP application. Its Advantage ERP application.
I had tried with other uiframeworks in uiexplorer and it is the same result.
In my case , i have got an order number and the bot needs to select the row where you find the order number, i do not see a search option as well , else i could have tried that, so if i get the selectors, i would need to iterate over the children and filter based on the given order number, that’s the plan.
I would not be able to use CV since it has license implication.
The application is launched locally on the same system as the bot. kind of stuck

Hi @sharmi_86 , this is on the same machine.

Hi @robinsonjoseph

One more question, may I also know whether you are using the latest UI Automation activities?

Also, there is another UI Automation activity pack called UIAutomation.Next… Have you tried that as well?

Try the latest versions of these two…

Hey @Lahiru.Fernando

i have not tried the latest, i missed that, i shall update you once i try with the latest packs.

Regards,
Robin

1 Like

Hi @Lahiru.Fernando

I tried with the latest ui automation packages, but still the result does not change, the whole area gets selected.
Any idea how i could use CV to help me click on a particular row in the table based on the order number

@robinsonjoseph , thanks for clarifying. Did you try data scrapping using different UI framework options? If not try changing the Ui framework type to UIA or AA .
image

Yes I had tried that already @sharmi_86