Delay problems


#1

Scenario: In citrix enviroment I need to write a string there but is taking 30 seconds to do that and If I just try that step in a single step just take 1 second do that, and also when I print in the output the time that is doing that activity just said 3 second max but that is not happening

Steps to reproduce: type into.

Current Behavior: inside a flow take 30 seconds do that.

Expected Behavior: I need that take just 1 or max 3 seconds is acceptable.

Studio/Robot/Orchestrator Version: Community Version 2018.1.3

Last stable behavior:
Last stable version:
OS Version: Windows 10
Others if Relevant: (workflow, logs, .net version, service pack, etc):
for example … this is the log …but in reality is taken more time that is showed in the log output.
Also I did just that part in another workflow and I put an invoke workflow file just trying do something that could work better but nothing,

image

Any idea how I could improve that? I need process a lot of information so each second is gold.


#2

Hi @carmen,

Instead of Type into, can you paste the values using Send Hotkey; that’s gonna be instantaneous.


#3

Hi @PD2 … I just forgot mentioned that I also tried with send hotkey and happens the same … :confused:


#4

What activity do you have before the Type Into, like is the page refreshing or loading after doing something; Try changing the WaitForReady property to None, this will not wait for the page to be completely loaded but still perform your activity; or Change the property to Interactive if it is a popup; or to Complete incase it is waiting for something;

There is another property called SimulateType check this checkbox

You have to play around the properties to suit your purpose.


#5

well I tried what you said and also is not working :frowning:

Before Type Into I have a Click Image, then the screen change and I tried before attaching the windows and also without attaching the windows with the new box where I need to write … nothing is working … :confused:


#6

The screen loads after you click the image right? place a highlight instead of type into and see how long it takes to get that done.


#7

mmm …looks like could work doing highlight but when I tried again and it didn’t.

First I tried and clicked and then so quick continued and highlighted and type inmediatly but then in my second tried and after is like it clicked ok then the screen changed and then it waited for 30 seconds and then it hightlighted and typed almost simultaniously.

I’m not understanding how is working that … :confused:


#8

I do… So there is your proof that its not the activity that is delaying, the system you are interfacing with is taking 30 seconds to focus on the Typing area… It could be due to the network latency.


#9

that so weird, I just changed the click that I did before for a send HotKey and now is working as I was expecting.

I didn’t understand the difference …anyways is working … thank you for your suggestions …