UiPath TypeInto is misbehaving in Citrix

I am trying to type input in Citrix environment (RDP) using “TypeInto” activity in UiPath. But UiPath is mistyping some letters. Some time it is typing Lower case to Upper case and vice versa even though i am trying to manage DelayBetweenActivities propety.

Please help me to solve this ASAP.

Welcome back to uipath community
Though we are making delay between keys kindly make sure that simulate type is disabled and send window message property is enabled or if not. We’d disable both and let it run by default method

Cheers @abhilashreddyalla


Thanks for reply @Palaniyappan

I have checked my code and in TypeInto propeties i am not selecting Simulate click or SendWindowMesage. Attaching propeties panel screenshot for your reference. Let me know if any change need to be done.

Kindly mention the Delay between keys property with commendable timestamp around 2000 milliseconds

If the type into is not working with selector then to make it stable use SEND HOT KEY activity with tab as key and use n number of send hot key activity with tab as key until it reaches the field
And once after reaching use type into activity without selecting any elements and finally use another send hot key activity with key as enter

Cheers @abhilashreddyalla

@Palaniyappan As i am doing Image automation there are no Selectors. UiPath is simply typing in activated window. Using timestamp around 2000 milliseconds will take so much time to type for large text.

I tried using hotkey like ctrl+c, ctrl+v but sometimes UiPath is typing ‘v’ instead of pasting. This mechanism ctrl+c, ctrl+v not working in Command prompt (Nested RDP).

I would actually try disabling all the other options, except “Activate”. I had some issues before with Citrix and SimulateType or SendWindowMessages. Disabling them all, and having a delay of 500ms seemed to have worked. It does mean that automation will not work in the background though.