Data Scraping Wizard does not extract all selected data

The problem I am having is I’m trying to use the Data Scraping Wizard to extract contact names and the company they work for from an internal application at my work.

All the contacts I need to extract the data from are on one page, 2117 contacts.

I have selected first name, last name, and company.

I have set the Max number of results to 0 and even tried 30, 40, 50. But no matter what I will only extract the top 29 contacts.

When I read other situations there was suggestions of using IE, I’ve tried after trying Chrome.

I have tried to select the first element as the first one in the list and the last one on the bottom, also in series.

I even tried to do it in reverse, first element is the last one on the list to the top one as the second element selected.

Just looking for help on this, it’s an internal project that I am attempting to actually promote the UIPath tool in our company so that we can possibly expand it to our clients.

Thanks

I think initially all the 2117 records are not loaded. Only the visible page data of 29 records are loaded. It will load only when we scroll down the page.

So you can try scroll down till end or send Hotkey of End. After that if you do data scraping, it may extract all the values.

@tayloj04
G’day folks!
I don’t think this is your problem, but please take a look at it. During my first data scraping project, I encountered this problem. I need to scrape nearly 75 car items (each with 3 column items) from a website, and it gives me 75 but incomplete data, ex. on first row there is no data for the first column, on other rows they have no data on their second or third column, others have correct and complete though. When I inspect, I found out that although they came from same table (which means they have same selectors), there are “mini” selectors (or sub-selectors) inside each table cell that makes it unreadable. For example, the first row has a badge, so the data scraping wizard thinks (maybe) that it is another / different selector (which does not belong to the table). IDK, correct me if I’m wrong for I’m not a guru ^_^.