Data Extraction Scope: Invalid Server Response (500)

Hi there, how are you doing? Hope it’s going fine!

I come with an issue today… I’m trying to test the Legal Contracts Data Extraction with UiPath Document Understanding and I get an Error I cannot locate in Data Extraction Scope Throws Exception At ML Extractor guidance. It is a Server timeout (500) Error from the extractor endpoint :sleepy:

So, in order to reproduce the issue I’ve followed the steps provided in the tuto(first link):

  1. I’ve well defined + extracted the document’s Taxonomy
  2. Since I have many legal contract types, I haven’t created the Classificator, we will use Document Type Id (from Taxonomy) instead of the result from Classification
  3. I’ve configured Data extarction with ML extractor so, I found in public endpoint list the one for Contracts in Western Europe: https://du.uipath.com/ie/contracts_preview, I’ve linked 2 test closures coming from the endpoint by deafult

Then:

I get the Timeout Error from the Endpoint. Here I paste the trace:

  • RemoteException wrapping UiPath.Shared.Activities.CorrelationIdException: Request CorrelationId: (…My correlation Id hash…)
    Invalid server response. —> RemoteException wrapping UiPath.DocumentUnderstanding.ML.Activities.Exceptions.MLRequestException: Invalid server response. —> RemoteException wrapping System.Exception: Response status code does not indicate success: 500 (Internal Server Error).

Since I get the features from the endpoint I can say I’ve tested the Endpoint is working and, I’m also already using the Document Understanding API Key in several projects so… Do you figure what could be failing here? I can’t :smiley:

Thanks in advance and Have a nice day UiPath family!

Hi, Does this occur in all your files or is it just for some files?

you are getting a timeout error in the machine learning extractor because it’s taking some time to extract large files. Please check the properties of the machine learning extractor. You need to increase the timeout response and test it again.

image

1 Like

Hi Sharon,
Thank you so much for your help,
I’ve upgraded timeout to 1000000000ms so 277h ( :smile: ) and it still gives the error after a while… so, We don’t reach timeout

So, 1st I tested with the test file given in the demo and it works (~200KB written pdf file, 11pages). Then I tried with the smallest contract I have ( 1MB image pdf file, 50pages) and it doesn’t.

I tried with UiPath Document OCR and OmniPage OCR engines to digitize (JIC)…

I wonder either if:
A. We have server timeout limit
B. We have data limit

Hi Jorge, you are probable having both server and memory exceeding limits. You might want to contact UiPath support to extend your license & OCR capabilities if you have one.

1 Like

Thanks Sharon, I will…
BTW I’ve found a solution, instead of getting pdfs signed so, pdfs all in image, I found a workaround:

  1. Ask for the documents in Word, so for each document, in UiPath

  2. Save it as pdf

  3. Use the pdf as Input

Then, it works. Anyway I’ll follow your advise of asking technical support to verify what’s happening behind

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.