Machine Learning Extractor Failed in 50_Extract Document Understanding Template

When I run the Document Understanding Project.

I receive this error

Its working fine with other machine but in my current working machine failed. Is it because of some connection issue or what? Is there any solution for this?
I have already give the correct API Key and configured the extractor correctly. Replaced activity and taxonomy.


Welcome to UiPath forum

Have a view on this thread where this issue was identified, discussed and solved

Hope this help u

Cheers @lean0919

@lean0919 Welcome to UiPath Community

Which approach your using the read the data is It “End Point” or “ML Skill” ?

Hi @lean0919 ,

Could you let us know if both the machines were connected to the same Cloud / Orchestrator instance ?

Im using ML Skill

Yes they are same

Have you select correct ML Skill?

as we can seen in the error info it is mentioned " Invalid response: content = ML Skill Unavailable code = unauthorized"

Minimum Confidence keep 50 % or try with 0


@lean0919 ,

Could you also make sure if the Folder used is the same in the Studio ?

Hi have you checked if your ML skill is public?

You can go to your ML skill > modify current deployment > Make ML skill Public


Hi, i resolved that, but now i updated my taxonomy again, from text data type to date, now it error again

Im so confused why failed, only the one without changes success

@lean0919 ,

It would be helpful if you could let us know what was the step taken to resolve the previous error.

In addition to the Error that you are receiving currently it might be due to the change of type as you have mentioned. Did it work before the taxonomy update ?

Also check your classification results that you are passing to the activity.

before the api key is in a variable, studio double quote it automatically from in_Config() to “in_Config()”, i removed and its fine

before was fine with text data type for some fields, but now i changed to date format for some fields, it failed now. Only the one without changes is success.

also the success one, i changed to number data type from text on it, its working fine tho, only the date format

I removed the trained classifier, it succeed, but if i train again, it failed

how come?

@lean0919 ,

Was the Keyword Training done for the Document types that you have ?

yes it is, done for each document types

Palaniyappan, do you have any idea for this, i still cannot fix this