CV Type into Activity

Hello Enthusiasts,

I’m trying to use CV Type into activity for an image on internet. It clicks on this image first, thus, another link opens. Im attaching, the image and the workflow. Can anyone tell me the reason for that?


Thank you,
Anusha

@Anusha_Makam

Within the properties pane of your ‘Type Into’, is the box checked for ClickBeforeTyping?

Hello @bradsterling,

Thank you, Yes that was the problem. .
Now i have unchecked that box, it behaves correctly , but it still doesn’t type into the block.Are you aware why that could happen?

Thank you,
Anusha

@Anusha_Makam

Have you completed the SAP training? I’m not sure how much you have worked with UiPath and SAP but there are some details which make it easier for UiPath to interact.

In terms of not typing into the block:

  1. Can you type into other places in SAP?
  2. If you highlight the selector, does it find the correct box?
  3. Have you tried checking the ‘Activate’ box in the properties pane?
  4. Does the ‘Type Into’ activity have data to write? It looks like ‘cv1’ is supposed to be typed from the first attachment.

This link my also help! SAP short cut for going to transaction code box

Also, to see exactly what’s happening, you can use debug:

  • go to Execute tab in Studio
  • in the Options button check Highlight Elements
  • and then run Debug

All activities will highlight their target location.
Let us know how that’s working, and if you can also post a video of it.

Hello @bradsterling,

This is just an image for which im trying CV. Activate button is checked.
Type into has data to type. Yes, cv1 was supposed to be typed into it.

Anusha.

@Anusha_Makam

A few more questions:

  1. What package update do you have for UiPath.UIAutomation.Activities? Since you’re using the prerelease UiPath.ComputerVision.Activities, make sure your UiPath.UIAutomation.Activities has v19.3.0-beta.223432.

  2. I tried to recreate your flow and was unsuccessful using CV activities. I would suggest moving the ‘Find CV Text’ before the ‘CV Type Into’ so its linear. My guess is UiPath is trying to find and type at the same time and that’s why you’re not able to type into.

  3. As @Cosin recommended, use debug and see if you can spot the error using highlight. Since this is in beta, it may be a bug that needs to be worked out. If so, can you please provide more information from the file, i.e. project dependencies, studio version, etc.

Hello @bradsterling,

I have used BetaFeed-https://www.myget.org/F/uipath and UiPath.UIAutomation.Activities v19.2 .

In case you have a file ready to use, please send a sample file.

Thank you,
Anusha

Please upgrade.