Copy Range as picture only works on Studio, not on Robot - different approach?

Dear all,

I need to add a screenshot of a specific range (with formatting) in Excel to an email.

Using Balareva’s EasyExcel CopyAs Picture activity, it works totally fine on the studio machines.
But when using the robot machine, it won’t work anymore. No image is being saved.

I even added delays before and after the activity, in case the robot is just too fast, also let the file be visible during that task.

Any ideas why this is happening?

(Using Studio 2022.10 now for a week)

I also tried different approaches how to save this range as picture:

  • copy as datatable, insert to Word file, save Word as PDF, extracting pictures from PDF file.
    → Problem: the inserted datatable is - of course - without format. So not usable.

  • save Excel workbook as PDF, extracting pictures from PDF file.
    → Problem: The last column of the table is on page 2 and the table is not recognized as picture. So nothing is being extracted.

  • Copy Data to Clipboard (Balareava Activity), str+v to Word document, save as PDF, extracting pictures from PDF file.
    → Problem: It looks nice now, but the table is still not recognized as picture.

Do you know of any other useful approach?

Thanks in advance for your input.


Hi @Juli ,

Could you Check the below post where a similar requirement was addressed :

Hi @supermanPunch,

This package activity is actually working also on the robot machine.

I found this solution also, but I missed the “UipathTEAM” part, and so I just assumed that I don’t have it in my Uipath.Excel Activities :stuck_out_tongue:

Still wondering why the Balareva is only working on Studio and not on the Robot.

But I got my result, so all fine :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.