Connection does not work in unattended mode

I created a Microsoft Sharepoint connection with the robot account in the correct modern folder to update a list item.
When I run the process in attended mode, it’s working fine. But when I run in unattended mode I have this error: Add List Item: User does not have Connections.View permissions on the folder.
The robot account has a View permission for Connections.
I don’t understand what is the problem…


Ideally when you create the process you would see the selection of connection while creating …did you select one connection there?

check this on how to find it


Yes, I selected the connection from the selection…


Is the connection access is present to robot? I mean that folder where the connection contains


yes the robot has access to the folder where the connection was created, and the connection is created for the robot user

Integration service is not accessible at tenant level (like most of the stuff from Orchestrator - Processes, Queues, Assets etc), it is using the cloud account settings of the machine that runs on instead. In your case in order to have connections visible you need to create them from the account that the machine is using while running unattended.