Combo-box in java applications not working

I am trying to use get text and sekect item activity for combo box in windows oracle application build in java. When I am trying to read combo box with get text, the result is blank and when I am using select item, I am getting error as Attribute is not supported by current uinode. I am using UiPath enterprise edition version 2019.4.4

1 Like

@Principal_htga Have you tried using Type Into Activity?

I have to read from the combo box

@Principal_htga Ok, Then Have you tried using Find Children Activity ?

how to use find children, I have no idea

@Principal_htga Can you use Click Activity and Show us the Selector in UiExplorer to get a View of the Selector in it

@Principal_htga Send a Screenshot of it, Since the Selector is not visible in here as Text :sweat_smile:


@supermanPunch Any solution ??

@Principal_htga Can you provide the Screenshot along with UiExplorer Window :sweat_smile: , It contains other attributes that are useful such as aaname


I am trying to read policy Issue State combo box

In UiExplorer, point to the combobox and look at the left inside Property Explorer if you can find the value in there (Iowa) in your case then it can be get using get attribute, if not, maybe only option is to get by Full Text…

@bcorrea I am getting all the values of combo box from get full text. But I have to read the value of combo box and match it with the excel data. By the way I am not getting Iowa in property explorer.

Just to make sure simpler stuff is working for you, confirm that Get Text is working for a text field like ‘Policy #’, Category or other text fields. If yes, than maybe use anchor base with image ocr to get that value…