Cloning Remote Azure DevOps Git Repository

I have cloned an Azure DevOps Git Repository down to UiPath studio plenty of times. Normally when I do this, I take the HTTPS url and copy and paste and then select an output directory. This has always worked except for the one project.

For this one project, I get an error saying "20.4.1 No UiPath Studio project was found in D:*ProjectName*. There is never a folder for the project in the directory when I do this and I have never had a problem. There is also a project.json file inside the repository that I am trying to clone.

Does anybody have an idea as to why this happens or how to fix it? Thank you

Hi @jpreziuso - Would you be able to post a screenshot of the folder structure here?

Also, were you able to download the project from Azure as a zip file and then open it using UiPath? Does it work when you do this?

Also, are you using the same machine where you were able to clone other projects without any problems?

Please keep me posted and I can find out a solution for this.

Thanks.


Not sure if these screenshots help. I have been able to zip the folder and open it in UiPath. However, when I do this, it is not longer connected to the Azure repository.

This is being done on the same machine as I have used in the past.

Thanks

Thanks. Can you follow the steps mentioned in the below link and confirm?

Hope this helps!

I have tried these steps before. When I click OK on the error message and it takes me to the directory, there is no project.json file inside (even though there is on in the folder in the repository). I think that is the root of the issue but I don’t know how to fix it

Hey,
weird - I always getting the error that ‘No UiPath Studio project was found’.
Every time I have to use a trick like here:

So how you are cloning without this message ?

Hi. I follow most of the same steps. I click Clone Repository, enter the URL and the Directory, and then when I click Open, I get that same error message you received.

I click ok and it takes me to a folder but there is no project.json file in there. I have tried downloading the project.json from the remote repository and placing it in there. But then the UiPath project opens with no workflows in it. Just a project.json file.

Any other ideas? Thanks for the help

Hey,
if you will use ‘pull’ it’s should download all files from repository.
image

If you are using branches - don’t forget switch to the one you need.

Ok that worked. Thank you. This is still confusing and frustrating why this happens randomly but this is a helpful workaround