Clicking Page 1 on Acme-Test Work items goes back to dashboard

Hello! I’m currently doing the Assignment #2 which is “Generate Monthly Report”
Previously, my Dispatcher was already finished and working properly. However, when I reset my Orchestrator Queues and re-run my dispatcher, my iexplorer were not functioning properly.

Every time page one is clicked, I get redirected back to Dashboard Page instead of refreshing the Page one page.

Screenshots are in here since i can’t upload images yet:

It was working properly before but when i cleared my iexplorer’s cache, i suddenly encountered this problem. I cant finish my Performer since I cant add items in my queue. Id like to know if there’s a way to fix my problem since it looks like the Acme-test Website is my problem.

@loginerror, @Pablito

Good sirs! I think this is a problem from UiPath Acme test site?

@ChesterLigutan

  1. Do you really need to click in page 1, because when you click on work item it automatically redirects to 1st page.
  2. You should recheck your code once and try to debug it using breakpoint and see selectors value your activities are referring to

I just did exactly what it says on Generate yearly report walkthrough pdf file,
i also tried changing my selector to in_TransactionItem+1.ToString to try and avoid clicking on Page one but it dont work :slightly_frowning_face:

@ChesterLigutan
Ok let me see, I have dispatcher already created, lets see how it works for me.

@ChesterLigutan

This is what i have used in click

<html title='ACME System 1 - Work Items' />
<webctrl aaname='{{in_TransactionItem}}' innertext='{{in_TransactionItem}}' />
1 Like

i tried your code, Thank you! but it’s still the same :frowning: , it still goes on clicking page one, but mine goes back to dashboard page when it clicks page one

@ChesterLigutan
This is weird, I ran my code for dispatcher and it worked like a bullet.

Your Xaml Navigate to Work item is under intiAllApplication right ?

@ChesterLigutan

Hey,

**Apologies**, It’s happening with me as well.
Something wrong with Acme web.

Hi!

Since some of our UiPath staff are not replying, just try submitting a ticket to UiPath regarding this.

1 Like

aah i see! i also think it’s the website that’s having problems

1 Like

Hi Guys,
Can you check now again? I’m checking ACME but seems that everything works fine for me. Eventually if anybody is able to record gif then I could send this as an evidence to proper team :slight_smile:

Here we go.
This was working fine before, when bot click on page 1 and as per the pdf, it was working fine.
Now the click navigates to home page.

1 Like

Thank you for this. I will report it to the team.
Meanwhile I observed that it’s because default link to “1” is different when you are at first page and other for rest pages:



So as a workaround you might use a link from second screen.

2 Likes

@Pablito

I have already done this, was just checking to reconfirm on issue.
@ChesterLigutan Please refer :- Clicking Page 1 on Acme-Test Work items goes back to dashboard

2 Likes

Thank for pointing it out! i tried the workaround by adding an extra Click activity to the page two so it works properly when it clicks page one, Thank you guys!

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.