Unable to execute Navigate to work items in REFramework in Advanced level assignment1

I have followed the below steps as per the PDF for the assigment.Only the first and the last workflows are working.System is logging in and then clicks on logout and closes.But not clicking on Work Items button in the website ACME System1.Kindly help me how to resolve this issue plz.
I think UI path is not able to invoke “System1 Navigate to Work Item” workflow which is inside the sequence in Init state.

Steps:
Open the Main workflow and expand the Init state by double clicking it.
o On the Entry region, locate where the KillAllProcesses workflow is invoked.
o Add a new sequence after the Invoke KillAllProcesses activity to read the input transactions data table.
o Inside this sequence, invoke four of the previously created workflows, as follows:
:black_small_square: System1 Login
Walkthrough – Calculate Client Security Hash 10
:black_small_square: System1 Navigate to Work Item
:black_small_square: System1 Extract Work Item Data Table
:black_small_square: System1 Close
o Import and bind arguments where necessary.

Change title attribute in the selector like below.
<html title='ACME System 1*' />

Hi Karthik thanks for the reply.
I tried your solution but still not working.getting the error message

show what your init seq looks like

I’m having a similar problem.
System1 closes after extracting input data.
Afterwards, it doesn’t navigate to Work items

1 Like

It could be because the web page isnt open when you are trying to navigate.
After extraction you close the webpage, post that do you open it again? you should also be on the WorkItems page so that navigate is also required.

  1. Extract (Init)
  2. Log out and Close (Init)
  3. Login (Intallapplications)
  4. Navigate to WorkItems (Process.xaml)

Once you do the above you should be good

1 Like

Thanks.
I did all that but then realized that my Config file had “https://acme-test.uipath.com/account/login” as System1 URL. I corrected it to “https://acme-test.uipath.com/” and it now works fine.

1 Like

Yea a common mistake of copy-n-paste from the browser url rather than using the PDD :slight_smile:

1 Like