Click image / Grab from screen

Hello, When I’m using ‘Grab from screen’ from the Click Image activity, my screen resolution get smaller while I try to grab the part I want on a pdf, the border get black and the pdf seems to go into a 1000 x something size, when I’m using a 1920 x 1080 screen resolution. I tried using Indicate Scope on Screen instead, working good but when I run the robot, I’m getting a error ‘OpenCV: Bad input roi’ and I feel its because of that.

Here what its look like when using ‘grab from screen’ from click image activity:

the yellow area is just fews program that I rather hide.
the black area is the place that should also be used to lets me grab from screen, but instead, its resize.

Any suggestion?


Hi @MaxyArthes
Before that use word application scope
Use add image or take screenshot activity it will take the image in an appropriate position
And use export to PDF activity


That seems like alots of manipulation for just getting information from a PDF, no? I feel like there a problem as why it resize my screen resolution and that should be the thing to be fixed, if I’m not wrong.

Added a image to the main post to explain the situation better.

Yah that’s the issue
Kindly change the screen resolution of the desktop
Did that got changed suddenly or due to bot
Cheers @MaxyArthes

1 Like

my laptop’s screen had 1920 x 1080 with a scaling of 125%, but I wanted to change my code to use 1920 x 1080 with a scaling of 100%, so now I’m using the studio on my second screen with 1920 x 1080, scaling of 100%, but I’m getting this issue every time I try to use a image activity. If I set the scaling to 125% on my second moniter, its work, but that still a problem as it 125%. The problem occur only when I use uipath on a Windows server (remote desktop to connect). If I do exactly the same directly on my laptop, there no issue, so I guess its concern something about the server but I can’t find what. Any idea?

1 Like

Was this preset and if so why do we need to change because the process we developed was for 125 percent and if we are trying to execute that for 100 percent of resolution we would get this issue

That’s the reason it was working fine for you when we were at 125%


the problem is that my laptop was in 125% when I coded it, but I want to code it back using 1920 x 1080 with a scaling of 100% because that would make it easier for the futur programmer that will deal with the project after me and also easier to run in a window server using the orchestrator, as by default, the server use a 100% scaling.

1 Like

Then to be very simple we can reselect the elements or image again with the same process with new screen resolution
Once that is done make sure that new process is published and so we can run that process without hindrance

Cheers @MaxyArthes

that won’t work tho as when I use ‘grab from screen’ from a Image activity I get the problem of UiPath changing my screen resolution as I showed on my first post…


I’m having this problem too, did you find any solution?