Click generic error

Hi Uipath,

Using the double click activity normally works, but i also keep getting this “click generic error” error come up, and I’ve changed the selector and created the activity again just in case. The double click is opening a folder in a Save As window on excel

any help would be great!

thank you

1 Like

Hi,

I encounter the same issue with the normal clic activity which gives me the error : “Click generic error”
Could you please help ?

Regards

hope your using recent version of UiPath.
can you give us scenario when you get that error.
May be you can attach workflow or selector.

I think this was due to a selector with not enough information.
But the message is really not clear…
I get a work-arround

I encounter a similar issue while clicking UI element. This is random and does not come all the time.
Any solution anyone found?

click activity has 2 properties, you can try adding one or the other and see if it can fix your issue.

image

Hi,
This automation is in production since 3 months and we encountered “click - generic error” today. Does using “send windows messages” or “simulateClick” resolve this issue.

1 Like

Hello

Same problem here. I’ve been testing the flow last friday and I didn’t get the issue.
I try again today (without any changes) and I get the same message.

Is there already a solution?

What studio version are you using exactly and what are you clicking?

Hi Any solution for this issue I am also getting it randomly at any part of code, I have tried with both Simulate and Send windows message option.

Hi Everyone , I had the same issue on a click of UIElement after finding an element . After verifying selectors i had found no change on the selector . and finally i have applied some delay before the click of an element .
Please try this approach .
Also if you are trying to change the selector content before a click , Make sure you do not use any generic variable int he selector

There is a web element in my application. I have to click on “New” button, then I have to click on “New XX” button. The first button is present in a menu and button itself is composed of 2 sub buttons, Im able to click on first button.

But I cant get the selector for second button as window vanishes. I tried recording using web but it records perfectly but when I run it, it gives click generic error. I have tried simulate click, also provided delay. Nothing is working. Please suggest

Hi Nikhil,

Click generic error is something that hasn’t been a good experience in my projects too.

These are the solutions that have worked for us.

  1. Keep continue on error as ‘True’ if the activity is happening but also throwing an error.
  2. Keep a separate try catch block and see whether the subsequent element exists and then retry.
  3. Have a stable selector and use Click image activity if all the environment resolutions is the same.
  4. Use a reliable selector which does not change and better to not be a minimalist when setting attributes for the selector.

These are the things that I follow and I haven’t faced any issues yet. Hope it helps

PS: Do not keep the loading as ‘INTERACTIVE’ rather keep it as ‘COMPLETE’ and also use both TimeoutMS and if and only if required use a configurable hardcoded delay before and after.

Even after this this issue exists then maybe throwing an exception and moving on might be the only thing to go about it.

Thanks Raghavendra. I cannot inspect it as it doesnt allow me to inspect it. Secondly I cannot bypass it as this is first step. I have handled this in selenium but in Uipath it is bit challenging for me.

I dont exactly know what the click generic error is or why it appears randomly during processes when migrating from environments to environments but, what I have found is using Simulate click (the web application should allow simulate command) rectifies most click generic error occurrences.

if you can be more specific we can dissect the problem.

Cheers :slight_smile:

same for me also. any solution?

For me I resolved the error by clearing browser cache.
Scenario : My web automation worked fine for approx 5000 transaction Ids but with time We realized that click generic errors are increasing. We did some research and found that in some cases crome was not responding.
We cleared browser cache and BIngoo! we were sorted. :slight_smile:

2 Likes