Click activity not working after modifications

I have modified the selector in many different ways possible, it may even work on the current page but when I load another patient it won’t work.
tried changing the parent patient id too which changes everytime.
attaching a snap of the selector before as UiPath scrapes it and after mod.




Hi @ItsChintav

You have pass one variable to two attributes innertext and visible innertext.
In the attributes check the innertext attribute only and pass the variable to it.
When passing the variable check the override value option. Then validate.

Note - When you are indicating the element check the strict selectors and uncheck the fuzzy selector and image. Open the properties of that Ui activity and open the strict selectors then open Ui explorer in this only you have to modify the selectors.

Hope it helps!!

This is edited in only the strict selectors.
innertext isn’t a problem but the parent id changes and putting a wildcard into it doesn’t solve the problem on hand.

tried overriding the variable too.
still not working

If the Parent Id is changing every time then uncheck that attribute in the selected item.
Don’t modify the multiple attributes just pass the variable to one attribute, in your use case it is InnerText.

Hope you understand!!

Did that too still the same results
either UI element not found or the activity will execute but won’t click on the required element.