Click a button in SAP GUI doesn't working except for hardware event input type

Hi all,

I have process to automate in SAP GUI application
all the click and type into I could automate it using Simulate and send window message input type except for these button in this table in the image they don’t support simulate click and when I used send window message the robot continue without error but no thing happened after clicking as same as the robot didn’t click any thing
note: when I used hardware event input type the robot working 100% but I need this process to work in Background

any suggestions?

Hi ,

Check if SAP Scripting is enabled.

1 Like

Hi,

yeah i also faced the similar issue earlier and it is due to some applications will not support simulate or send window messages it will support only hardware events. i am not sure your application is similar i guess.

one thing could you please check at your end we have to enable simulate click or send windows messages we cannot use both at a time. use only simulate click or simulate type into and fully disable the other option send window message by un check the checkbox and see if it works. thanks.

1 Like

sure dear you cannot automate any thing without Scripting is enabled in SAP GUI.
and every thing is working for me, only these button I cannot click.

thanks for your reply dear :blush:

thanks for your answer dear

sure I enable only one input type in each time and disable the other, and the problem is same

ok .thanks for your response. we need to explore the options on alternative ways to perform back ground automation without simulate or send window messages if the case application is not supported.

1 Like

some times I am using send hot key to send tab and enter instead of click but in my current Process no key I can send it to reach for this button

just wanted to check did you already tried with the option wait for page load → complete while opting the simulate option. Thanks.

HI @Mohammed_Bakr

Show us please UiPath Studio and

  1. selectors of working “type Into”
  2. selector of not working button

In which SAP WinGUI transaction you are?

Then we will see more.

Best regards, Lev

Do you have a specific restriction not using the ‘hardware’ clicks?
It is well know that not all components respond to windows message or simulate click. I’m afraid you just found a few. (To be honest my previous experiences with SAP GUI was way worse!)

If they do work with hardware clicks, it means your selectors are valid, and the process data throughput is valid.

Is this blocking for your automation? Or merely an academic excersize to try and solve it? IN case of the second I’d suggest using hardware and moving on… (I can appreaciate the academics as well though! :slight_smile: )

Hi Mr. Lev,

Thank you for your response,

I will share all information about the process.
in the first image, the robot did select item activities successfully for the tow fields in black circuit, then executed 5 type into activities with simulate type for the header 5 fields in header, next the first item in this order will be selected by default so the robot executed click activity with simulate type to click on “Where” button in blue circuit then started fill those three fields in yellow for the first item with simulate input type, after this step the robot should click on number 2 button which is under the red circuit and the problem appeared:
when I select simulate for this click activity the robot throw error that (this element does not support simulate input type) so I select send window message in this case the robot didn’t throw error but the robot didn’t click any thing

Thank you dear, I am waiting for your advice.

I tried dear, also the same

Hi @Mohammed_Bakr

I have one idea, please share the full selector, which is not working.

As of now, I see some wildcards * inside. I want to see the whole original selector of SAP

Regards, Lev

this is the selector as it is

@Mohammed_Bakr

Selector looks good. I have no more worries here. Thanks!

Other question: what is the reason, that you want to perform Simulate Click on this button, why not to use simple click?

Thanks, Lev

1 Like

Simple click that is mean Hardware Event input type?

If you mean it, So in this case the process will not working in background or under windows Lock screen, for that I am using only Simulate and send window message

@Mohammed_Bakr

I was able to reproduce this behaviour also on my machine.

This settings works perfect

If I select “SimulateClick” it does not work anymore… Need to check with my team.

In meantime, @StefanSchnell do you have an idea how to automate this button “in background”?

Transaction is MIGO

Best regards, Lev

1 Like

BAPIs? :slight_smile: but the BAPI is using MB01, not MIGO … anyway, doing the same thing

2 Likes

Agree, BAPI would be the better and much faster way for background automation.

1 Like

@Mohammed_Bakr

You can try with Set Text activity also

Hope this may help you

Thanks