Chrome extension issue on right-click

When trying to use the right-click activity in Chrome I keep getting the error “You need to install and enable the UiPath browser extension for chrome before continuing.” although the extension is installed. I’ve followed the steps in this guide. The ChromeNativeMessaging.exe process IS running but in my registry there’s no HKEY_CURRENT_USER\SOFTWARE\Google\Chrome\NativeMessagingHosts\com.uipath.chromenativemsg_v2 key. There’s also no manifest.json file in the expected location, C:\Users\YOUR_USER_NAME\AppData\Local\UiPath.

Software:
UiPath: Studio 2019.10.5 - 6/9/2020, Academic Alliance License
UiPath Web Automation: Version 9.0.6824
Chrome: Version 86.0.4240.75 (Official Build) (64-bit)
OS: Microsoft Windows 10 Home 64-bit, .NET Framework Version 4.7.2 or later

Hi @hunsballe

In uipath studio you need to go to extension and click chrome and check it

Thanks
Ashwin.S

Hi @AshwinS2. Thanks. Can you be a tad more specific? Are you referring to the Home > Tools > UiPath Extensions and that I need to reinstall from there? I’ve done that 10 times to no avail. Also reinstalled from the main UiPath installation file.
I can’t see any menu or area named extension as you mention where I can check anything.
/Jes

Hi @hunsballe

Have you added uipath in Chrome ?

Thanks
Ashwin S

Hi @AshwinS2
I am not fully sure I understand what you are asking since I did mention in the first message that the UiPath Web Automation extension is installed. Is there another way to “add UiPath in Chrome” - not sure what it means? The extension is running fine apart from the case I mentioned. I’ve ticked “Allow incognito” and “Allow access to file URLs”. UiPath only gives the error message when I use the right click activity followed by a click activity on the browser menu in UiPath Studio. I can do plenty of other browser automation activities without errors.

@hunsballe
Have you tried using Simulate Right Click?

Hi @MichaelL
Yes, I’ve tried the various methods available to execute the right-click. It’s the same error.

Hi @hunsballe

Have you tried the troubleshooting guide from our docs? I would say that the registry entry is important for the extension to work.

One way to try the install would be to go to the UiPath folder and try the command line installation options (see the docs for details, for community edition the path will be slightly different, in %localappdata%\UiPath).

The command line tool has a command for a /chromecleanup as well as several options to install it, both per user, globally, and as a policy.

I have the same error occurred.