Changing remote authentication to private key from password

I have setup a Git repo for my project, and to get started I entered my credentials. Git sent me a mail telling me that passwords will be deprecated (as they should), and I should use a private key. I don’t see where I change my authentication from password to private key.

@kbak you can also use token authentication as more secure method: Managing Projects with GIT

Yup, I saw that when setting up my repo. However, as far as I can tell (and as the documentation states), this option is only available when you setup your repo. Once I have selected password, I’m stuck. It’s not possible to fix it by merely deleting my repo, so I don’t know what to do.

This seems like an oversight.