Capturing WEB elements issue

Hi everyone,

I’m trying to automate a web page, meaning that I want to iterate through different lines that are displayed on a single page. How can I identify using UiPath studio, the line items displayed on a webpage.
For example, on a page I have 4 lines (entry points), and I want to ask the robot to perform a specific action on the 3rd line. I used Recorder, but it doesn’t work because is always identifying the 1st line.

Many thanks!

Hi @LisaC can u ealborate ur query with the screenshot of webpage that u are trying to automate?


Here the screenshot of an example of how the lines are displayed.


Is the description_test is the lines u need @LisaC

No, the lines I need are numbered as 10 and 20, in front of them you see that I have that checkmark.
I want to modify for example the quantity from line 2 (No. 20 in the printscrn), but in order to do that, UiPath needs to identify this line.
The purpose is to iterate through each line, and I don’t know how to do this, since using recorder it only goes to the first line…



Can you share the selectors of Part# in No. 10 & 20



See some screenshots with the selectors behind both lines. Note that I used a type into activity (using recorder for web) just to show you what is behind Part no field as requested.

Can u show the uiexplorer part @LisaC


Can you expand UiExplorer and search which is a Unique element

according to that you can able to differentiate

Hope this helps you


Ideally @LisaC you should have a specifi selector for each line. What we would need to do is we need to assign a “variable” in replacement to the value of the selector. This will allow you to go through one line accordingly.

Are you able to open this in UiExplorer instead?

Thanks Sean,
I managed to assign the variable and replaced the selector with it. Now it works.

Hi ,

Thanks, it works now . I found the unique element which helped me .

1 Like

Cool Cool! Glad it worked


I’m still having problems with this WEB page automation. I thought it works but in fact I noticed that I have a problem with an “if” condition.
I’m trying to do a cross check between the value from an excel file and the one from the web page (line number 10 - from the above screenshot).
Even the value from the webpage is exactly the same with the one from my excel , when I run the project, it is saying that there is no match between them.
Any idea why is this happening? Thanks.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.