Can't Retrieve License from Orchestrator

I’ve followed the instructions as listed in WORKAROUND: "Device ID already activated" error

But it just won’t retrieve the license. Here’s the robot that I’ve created

1 Like

Seems like your Robot is not connected to Orchestrator. Goto and connect your device. Then try activating using Orchestrator License. If you have trouble connecting your device with Orchestrator check this Connecting Robots to Orchestrator

Hey, thanks for responding. So I’ve followed the instructions accordingly but it shows the following error


Which machine is the msg referring to?

Please refer this page Orchestrator error “the machine key is linked to another machine” - #4 by cristi_pufu

I believe this should be the source of the issue


And I’ve checked the Robot Settings, it connected to the right machine

Did you try deleting this Robot and creating a new one?

Yep, just tried that. It’s still not connected, but this time for a different reason. You see since this is my first time using an Orchestrator, I wasn’t aware that the machine name needs to be named appropriately


So, I created another machine on Orchestrator with the exact same name as the local machine and replaced the robot with a newly created one. However, the same error is being generated again with the appropriate machine name and key



Hi, I’ve just created another topic(Robot created in Orchestrator not connected to Machine while acquiring licence for Community Version) since the issue I’m facing right now is no longer relevant to the current topic. But you’re free to reply here if you find it more convenient to do so.