Can't Create new Service?

Hi All,

Been trying to connect an API to a UiPath Studio Library and it doesn’t seem possible for me. I need to connect the API to an openText server and although I can connect to the WSDL file, when I try to save it I get the following error (Refer to picture below)? I have also tried SOAP client and when I run I get the following Errors below? Something about getting a xml response back vs a html? How can I change it so I don’t get this error? I planned to invoke some C# code to fetch and upload files within the openText folder with uiPath without having to do simulated clicks and such, but don’t know how to resolve these issues as UiPath doesn’t provide anything except “Selected Activities could not be compiled”.

RemoteException wrapping System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. —> RemoteException wrapping System.ServiceModel.ProtocolException: The content type text/html; charset=UTF-8 of the response message does not match the content type of the binding (text/xml; charset=utf-8). If using a custom encoder,
be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: '#content

image

Thanks,
Jeff

I dont think i fully understand what you explain here, are you trying to create a custom activity to include in an uipath project, and inside it you are trying to reach some api, or are you trying to create a service inside a library?

I’m actually just trying to add a Service but when i hit Save like in the picture I get the Selected activities could not be compiled. Essentially need to run SOAP request apis to communicate with an openText server. However the red error at the bottom shows up and I have no idea why the error comes up since the wsdl works fine with other programming languages when imported.