How do I setup an SOAP Request using a .p12 certificate?

Hi everyone,
I’m running UIPath Studio version 2020.10.2
First of all I have testet my setup succesfully in SOAPUI and now know that it works.

But I’m having problems when I try to set up my soap webservice request in UIPath.

I’m doing this:

  1. Dragging the activity “SOAP Request” into my sequence and the wizard starts up.
  2. As the UIPath video did I put in the url that provides the wsdl in “Service Description”.
  3. Click “Get” and get this Error.

After that I tried just the endpoint (above without “?wsdl”) and get this error:

I have also tried with “Get” on the wsdl-file and get this error:

And if fill out “Authentication” = Client Certificate with the correct path and password. This give me this error:

I have even tried ignorring the wizard filled in everything myself:


And get an 403: Forbidden request respons.

Anyone who can help me here?

Regards,
Peder Gullacksen

Hi @Peder_Gullacksen

Welcome to our UiPath Forum! :slight_smile:

It might be better to create a library project, load your service in and then expose the endpoints via library package activities, see here:

Thanks for your answer.
It didn’t the “load” or “Get”. It’s like UIPath can’t give me the webservice “operations” or functions. You know the “SendRequest” and “GetRespone”.

I’ve opened the endpoint in a browser and I it seems like I need to “Open a Client()” before an applikation can use it.

Here’s screenshot from the browser:

I don’t how to do this with UIPath.

Anyone have an Idea?

Normally, the wsdl definition file should be enough.

I found this file that might shine some light on the issue:

It looks relevant from here on:

In general, if you manage to have to wsdl file stored on your hard drive, it should work with UiPath Studio as well (given that the instruction is for Visual Studio).

I’ll tag @alexandru for more input here.

Hi Maciej,

You found the right wsdl/webservice description.

I followed the description when I tested the connection in SOAPUI and it works fine. The problem is that UIPath doesn’t to “resolve” the wsdl correctly so it can give me the operations GetRequest and SendResponse for the webservice.
UIPath says that “wsdl file/document contains links that could not be resolved.”

@loginerror
I stand corrected on “6.1”. I didn’t need to save and do find/replace with SOAPUI.
I followed “6.1” and thru to the end.
This fixed the “load/get” problem. THANKS!!!

An additional question:
How you I convert my String variable with all my xlm in to XmlElement.

It seems like the “Deserialize XML” only creates an XmlDocument, so how do I get the XmlElement out of a XmlDocument?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.