Adding app.config to Web Service? Missing ServiceModel error

So I’m trying to run a webservice, but it has been a nightmare trying to link it to UiPath, I finally managed to get the API to download via the wsdl. But then when running the Activity generated I get a type mismatch in response error? Is there a easy spot I can change this somewhere?

I am not used to UiPath enough when it comes down to custom activities, since the flexibility seems limited compared to real IDEs like Visual Studio and Eclipse where I can likely specify a app.config file somewhere. I’m sure UiPath has the ability to specify but I have tried putting a config file in the project directory, adding System.serviceModel namespace, and nothing works.

I’ve already looked at other forum post like this and have no idea how they got it to work since I also tried to add the service model to the UiPath.Executor.exe.config hoping this is the “app.config” that uipath relies on.

Other things I’m trying now is instead of using the Service generated activities, I have gone ahead to add the service to the namespace and run my own C# code, I’ve added all my needed dependencies and libraries and got it all to compile… Then running it I get this issue.

All I’m trying to do right now is run an Authentication web service that is suppose to spew out a token when you pass in a username and password. Any help on this matter is greatly appreciated.

Hi,
Did you guys manage to find a solution for this ?
Regards