Cannot type special keys using Simulate Input mode

Hi - I am having issues getting the first project for StudioX to work properly. I am trying to use the ‘Type Into’ resource in order to type “Currency to USD” into the Chrome search bar but keep getting an error, which states “Cannot type special keys using Simulate Input mode”. When I check Properties, it seems to be fine, and the Input mode is set to “Same as App/Browser”. I have tried uninstalling the Chrome extension and reinstalling it, re-selecting the target on screen, etc., but cannot seem to make this work properly. It seems to run just fine before the ‘Type Into’ resource, so I’m guessing the issue is in the last resource I added. Any advice on how to debug this? Any help would be greatly appreciated.

I am also stuck there as well, i am have the same ISSUE

1 Like

The same issue((

Anyone figured this out yet?

I’m not sure if this is the right fix, but I managed to run it now without the error.
First, click the ‘card’ thingy of “Type Into ‘currency to usd’” then click the properties tab on the rightmost part of the StudioX window. I changed the “Input mode” to Hardware Events.

4 Likes

Thank you! It works

This worked for me too. Thank you and it actually makes sense. The input mode for Google IS use app/web BUT think about typing INTO google. You’re simulating a hardware event of the keyboard.

Thanks again for pointing this out and perhaps they can update the training.

Thank you! This worked for me. Don’t know why I didn’t think of the keyboard function as a hardware event, but I should have. Much appreciated.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.