Cannot sign when install UiPath Studio by service URL or Machine Key

I’m glad you found the solution! Please share some details so that it might be easier for other users with the same error “The operation has timed out.” in the future :slight_smile:

Maybe there is something that can be improved here as well (better error message, etc).

1 Like

The only error message is “The operation has timed out”, no other error message.
The sign-in button just no response.

There is no issue before this month working in my home, it happens a week before, but I don’t have time to solve the issue that time, after back office, the issue was auto recovered.

After I did reinstall UiPath few rounds still cannot solve the issue, so I think maybe try other location. I just change an IP address to test, so the problem solved by luck.


I tried to help him with a private contact, (we became friends :smiley: :sunglasses: )
Then I saw that Asking License key in the studio, I never see that kind of thing in a community edition, but @xiexfeng confirmed that he using CE,

Im not still very sure if @xiexfeng in Japan or China (pardon me if I’m wrong :crazy_face:), as the reason for saying if you change the IP its work means that did your country blocking the continues connection or something else (like a great wall :nerd_face: ) , don’t know but just an idea, because I was in the chain but bit of hard to connect with the network as their country firewall

@Maneesha_de_silva, I am in Singapore, it is not my ip address 58.96.. cause the issue, it is the wireless router assigned address cause the error. no issue after change it to

1 Like

hehe @xiexfeng sorry for not identified the country, so Singapore I hope there is no such kind of security instit. anyway, any finding via event log

Sorry, I am not IT trained person, don’t know how to check the event log, it is ok to me as long as the software can be used.

1 Like


I am also facing same error, can anyone explain me little bit detail please.
In my UiPath Assistant, Sign-in option also not showing.

And the “The operation timed out error”.

MicrosoftTeams-image (8)

Please help and thanks in advance…

Hi @Swetha_V

Have you managed to resolve this issue? It looks like some firewall would be blocking the connectivity here.

Hi @loginerror,

It got resolved for somedays now i am facing the same issue again. If i connect to VPN it is working fine. Without VPN it is not working.