Can't sign in to UIPath Studio & Assistant

New to UIPath. Having trouble signing into Studio and Assistant. I’ve tried all the connection types and each one fails. The default type, Service URL, says “Interactive sign-in is not enabled for this tenant”. All the online help references old versions of Orchestrator. The options they suggest for enabling interactive sign-in do not exist on the current Orchestrator pages - screen are different. I tried Machine Key connection type and although I have a Machine Key, and the Machine Name matches my machine, I get “Invalid machine key” even though the key matches. Any suggestions?

1 Like

Are you using the community edition?

if you are using an enterprise edition, try using the windows icon which will translate your active directory credentials (windows credentials) to UiPath.

Community edition


Make sure that you have followed the steps as per this doc

Check this doc on how to switch from machine key to interactive sign in

Cheers @mikea59


Check below for your reference

Hope this will help you


HI @mikea59

Have a look on document


Thanks for all the helpful advice. Turns out I did not have my Service URL set right - I feel really dumb.

Still, I’m wondering why all the online docs on this subject seem out of date. My Orchestrator pages do not match with what I see in the docs. For example, the Security tab is now called Robot Security, and the content is different. Not a huge deal, just causes some concern about the docs in general - are they up to date?

Documentation will updated periodically after the product release is what I have observed so far
So it should be fine in some days

Any further queries on this topic

Cheers @mikea59

This is true. I failed to sign-in at desktop PC even though I follow the steps to setup Orchestrator, and even un-install and re-install many times to try.

But, I successfully sign-in at laptop without any steps to set anything.

I wondered it is network problem, or settings of browser, since UiPath failed to redirect to sign-in page at browser while I pressed the sign-in button.


If you are behind any Corporate network, then it’s better to check with a public network

Hope this may help you


1 Like


yes, thank you a lot. I tested connect corporate network to laptop and sign out UiPath, then cannot sign-in again. While reconnect to public wifi network, signin process work again.

That’s nice to hear that you are able to connect via public wifi network
So, now you need to reach to your network administrator and ask if they can allow below link ip address to work from behind the corporate network also

If this post helps, Please mark as Solution, so that others with the same problem can be benefited