Cannot sign when install UiPath Studio by service URL or Machine Key

I had similar problem, and this helped me:

my uipath assistance don’t have sign in button, even have sign in button, but not response by click on the button.

After I reinstall UiPath as offline model, there is a login menu in UiPath Assistance. But still useless.

There is no running Robot Service by searching Windows 10 service.msi

@loginerror do you have any tip for a friend? I don’t know how to help anymore to @xiexfeng

i did this, doesn’t help



Try set the licence type to Studio not to StudioPro.

Let’s first try to solve the first issue. I think the name of the machine in Orchestrator is case sensitive and needs to match the name of your Windows machine.

On the screenshot from the post I reply to, there is a difference between the two (both in extra characters and different letter case).

As to the second issue, is it possible that you had both installs at one point - enterprise msi and community exe?


i should try small letter.

I am using community exe.


i don’t have Studio licence, but I have studioPro licence, so I set the robot as studio Pro.
same studio install, i had choose StudioPro

the installation is downloaded from highlighted.

@loginerror @Adrian_Star I have cleaned all UiPath folder after uninstall Uipath. and reinstall. still cannot solve the issue.

Here is my Uipath diagnositc report :
DiagnosticToolExport-24-Nov-20.zip (2.1 MB)

I have changed to a new notebook, same issue.

@Adrian_Star, how to switch to Studio from StudioPro ? there is no licence for Studio, but only StudioPro.

I have change my region to English (US) also. it doesn’t help.

Thank you for help.

If you are installing the UiPath Community version, Studio for learning is sufficient.
If, on the other hand, you bought a license: in my opinion, you should contact UiPath Support.

I can’t help this way. Too many variables. I think there should be remote assistance in that case.

@Adrian_Star thank you very much.

I may learn from issues.

Hi @xiexfeng,

I have read the other posts in the thread so somewhat understand the things you already tried. I also went through the Diagnostic Logs - I dont see anything which can help us since the first thing UiPathStudio.exe or Robot.exe do is look for orchestrator and check license.

My analysis is that this is issue realted to multiple versions trying to connect to different folder (Classic and modern) types in the tenant in Orchestrator.

Could you try this?
Since I see you installed the latest version of UiPath Studio 20.10.2 from the logs, I would request you to ditch the classic folder and only use modern folders in Orchestrator. Why? It is because in a modern folder all you have to provide users, which machine they are using and what license they are allowed. (If using unattended provide the windows password)

Then you can create a machine template instead of individual machines. Copy the machine key of the machine template and use the robot.exe -connect command as you said before:

UiRobot.exe --connect -url <YOUR_ORCHESTRATOR_URL> -key 072c0bfe-c4b5-****

The other advantage with the modern folder is that you dont worry about provisioning robots or studio/studio pro. A user itself can be given these and every user has a machine (when creating users).

2 Likes

I do agree with @jeevith that using a modern folder is the better thing moving forward.

But just to properly debug the first issue, here’s the correct setup:

Thank you everyone.

I just change my home internet from 192.168.1.1 to 192.168.0.1.

The issue is solved.

4 Likes

I’m glad you found the solution! Please share some details so that it might be easier for other users with the same error “The operation has timed out.” in the future :slight_smile:

Maybe there is something that can be improved here as well (better error message, etc).

1 Like

The only error message is “The operation has timed out”, no other error message.
The sign-in button just no response.

There is no issue before this month working in my home, it happens a week before, but I don’t have time to solve the issue that time, after back office, the issue was auto recovered.

After I did reinstall UiPath few rounds still cannot solve the issue, so I think maybe try other location. I just change an IP address to test, so the problem solved by luck.

3 Likes

@loginerror
I tried to help him with a private contact, (we became friends :smiley: :sunglasses: )
Then I saw that Asking License key in the studio, I never see that kind of thing in a community edition, but @xiexfeng confirmed that he using CE,

Im not still very sure if @xiexfeng in Japan or China (pardon me if I’m wrong :crazy_face:), as the reason for saying if you change the IP its work means that did your country blocking the continues connection or something else (like a great wall :nerd_face: ) , don’t know but just an idea, because I was in the chain but bit of hard to connect with the network as their country firewall

@Maneesha_de_silva, I am in Singapore, it is not my ip address 58.96.. cause the issue, it is the wireless router assigned address 192.168.1.1 cause the error. no issue after change it to 192.168.0.1.

1 Like