Cannot run batch file for attended bot local deployment

Hello everyone, I am relatively new to UiPath and have been encountering an issue with trying to deploy my bot project.

We are planning to deploy bots locally on our internal network, and have it set up in the usual way I’ve seen online, with the .nupkg file published from studio, and a batch script that points the UiRobot to run the file. This is in the form of: “C:\users.…\UiRobot.exe” -f “Z:.…\bot.nupkg”

I have the full installation of enterprise studio, assistant, etc and when I run the script it works fine.

However if a team member who installs only the “Attended Robot” installation, tries to run the script (after changing the file paths) it won’t launch. Does anyone have any solutions? Thank you.


welcome to the community

does i throw an error?

can you try to give as log as first action and check if you can see that


When I run the script, it opens up a command prompt window and then an app with a green icon begins to run the bot in the background. When someone else runs the script, only the command prompt window pops up and nothing happens after.


Please check event viewer logs to see if there is any issue


Why are you trying to run it like this?
The attended user can just run it from the assistant, you can even make shortcuts to automations from the assistant if you want to run them directly.

Perhaps were are unaware of this? Its much easier than messing around with some command line scripts etc.

There’s a lot of restrictions around firewalls, proxies, etc. No orchestrator, no assistant. So basically going the most barebones manual way.

How do you expect to run a robot without the Assistant installed?
Attended robots run via the assistant essentially, either way its required as that manages the licence.

Sorry, meant to say that the assistant is installed on the machine, but not signed in.

Then again, you cannot run it since without signing in you won’t have a licence.

Hm ok, if they go through the Studio installation path instead it prompts for licenses. Alright thanks!