Cannot get UiPath to recognize Java

I am having trouble identify any selectors at all in the Java application I am trying to automate. I re-installed the Java Extension per instruction but have not had any luck. Help me!

Please follow this guide:

Followed all those steps and still having problems.

Well in that case maybe opening a support ticket might be the case for you…

How do I do that?

May I know what edition we are using
CE or Enterprise and version also pls
Cheers @Mitchell_Binder

UiPath Studio 2018.2.6 Enterprise Edition

Were we facing this issue so far or this is the first time we are facing @Mitchell_Binder

I wasn’t having any issues and then suddenly, yesterday, it stopped recognizing elements within Java. I tried to re-install the Java extension a few times but nothing has changed.

1 Like

We can tell whether or not the extension is properly installed by the generated selectors for Java controls.

  • Valid Selector for Java Controls
<wnd app=”...” /><java role=”...” />
  • Invalid Selector for Java Controls
<wnd app=”...” /><ctrl role=”client” />

So which is the one we get
Cheers @Mitchell_Binder

The only selector I can actually identify in the window is:

wnd app=‘jp2launcher.exe’ cls=‘SunAwtFrame’ title=‘Server Console’/

It will not go any deeper than that.

Before these selectors went bad, I was able to grab selectors with “java role” and “java name” and “java idx”

So SunAwtFrame is fine
Are we using any of three kinds of application
Java Swing, Oracle Forms, Fujitsu JBK
Cheers @Mitchell_Binder

I am not sure, how do I find out

1 Like

I hope your cls attribute tells that, so your java extension is fine I hope (not sure completely, need to check once in a technical background)

But the document itself will help us to identify the issue
Like did we try with this option
You can also verify if the extension files have been properly installed:

  • Using a text editor, such as Notepad++, open the accessibility.properties file, which is located in the C:\Program Files (x86)\Java\jre1.8.0_xx\lib folder. If the extension is properly installed, the file should contain assistive_technologies=UiPath.UiPathBridge .
  • In the C:\Program Files (x86)\Java\jre1.8.0_xx\lib\ext folder, you should find the UiPathBridge.jar file.
  • In the C:\Program Files (x86)\Java\jre1.8.0_xx\bin folder, you should find UiPathJavaBridgeV8.dll or UiPathJavaBridgeV8_x64.dll .

Note:

If any of the previous requirements are not met, you can try to reinstall the extension as explained above, or fix them manually.

Hope I m not troubling you…sorry if I m
With the help of that document I would like to make it clear from our side before we approach
Cheers @Mitchell_Binder

1 Like
  • the accessibility.properties file is present at the correct location. (See attached screenshot, is this correct?)
  • ‘UiPathBridge.jar’ file is present at the correct location
  • UiPathJavaBridgeV8.dll is present at the correct location

!

Hi @Mitchell_Binder
If you are using 18.2 the java troubleshooting documentation is this one https://docs.uipath.com/studio/v2018.2/docs/java-extension

The extension has changed in 18.3 and the newer documentation may not apply to you.

@Mitchell_Binder were you able to solve your issue?
I have installed with success uipath java extension, I have verified and the extension files have been properly installed but the generated invalid selectors for Java controls.
Can someone help me?

1 Like

@Mitchell_Binder I’m curious as well. I’m having issues with the Java extension. I’ve installed it and verified it via the documentation above. The UiExplorer is able to identify elements on the first time of use when I load the application. But then after navigating within the app, the UI explorer no longer works or selects elements…

I’m on UiPath 2019.4.3 Enterprise Edition using JRE Version 8.

I have had a similar issue with a Java app embedded in a web page I am trying to automate. I was actually able to get this to for a brief period of time, but now it has stopped working. I have tried it on different machines with Studio installed.

I verified that the UIPath Java extension is working.

I can select the menu item in UI Explorer, but once the menu disappears it can never find that Approve menu item selector again. When the robot runs the automation it can activate the Approval drop down menu but can never find the Approve menu item and click it. I have tried using hot keys, and the down keys seem to work but the enter key never selects the menu item. I have also tried using SetFocus activities as well has hover and delays. Here are some screen shots of the app and my automation.

image

image

I am unable to get it to click on the Approve menu item. It errors with not being able to find the selector.
image

We are on UIPath Studio Enterprise 2019.10.4

Just wondering if anyone had any more experience with this and has a suggestion.

Thank you in advance!