Cannot find the UI element corresponding to selector - button clicks

Using a website , and to complete the action i need to first click a button which then prompts a pop-up which i then also need to click a button to get by.

I get the Cannot find the UI element corresponding to selector. Anyone got any ideas?

I will copy the whole error below this, thanks.


Source: Click ‘BUTTON’

Message: Cannot find the UI element corresponding to this selector:

Exception Type: UiPath.Core.SelectorNotFoundException

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
UiPath.Core.SelectorNotFoundException: Cannot find the UI element corresponding to this selector: ----> System.Runtime.InteropServices.COMException: Cannot find the UI element corresponding to this selector:
at UiPath.UiNodeClass.FindFirst(UiFindScope scope, String nodeID)
at UiPath.Core.UiElement.FindFirst(FindScope scope, Selector selector, IVariableResolver resolver)
— End of inner ExceptionDetail stack trace —
at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

Hi @shawnmurray
Have you already checked the selector?
Are there any dynamic parts in the selector?
Thank you :slight_smile:

Check some points
Is the selector Dynamic? (Changes every time page loads)
Is the selector pointing to desired element?
Use Debug features to understand what’s happening inside

Where or how do i check that the selector is dynamic?
I have used highlight in UI Explorer and it is pointing to the desired button.

Hi Shawn

What site are you automating on? Can you share the selector you are using?

Also, are you using a full selector or attach browser activity?

Hi @shawnmurray - Dynamic is something that in the Selector some of the value gets changed every time you get it into that Page for that particular action. Check whether its an image or button.


For example, sometimes elements has a “idx” or “id” property that can vary. Our suggestion is Evaluate Selector to check if some part of selector could change in every execution. You can use Debug Features putting a breakpoint to check if Element is detected correctly.

I am automating on linkedIn to automate connecting with people

Is there a way to check if them elements do change because with running a search at the beginning it requires the page to load everytime?

Hi, it seems to me that it is definitely a button…


Even you could send the “enter” keypress instead performin a click, after you type into search field

@shawnmurray - Open Ui Explorer and send the screen shot. Let see what and all listed over there.


Try replacing the Ember521 with Ember*

I’ve just tried adding a few people and each one has a unique ember reference number.

This may be your problem

1 Like

@asesor-rpa I will explain the process i run a search on LinkedIn using names from an excel sheet which works fine, hits enter to search then tries to click the “Connect” button to connect with the person and i get an error, the enter key wont work here.

@AnandKumar26 Please see attached

I could suggest use Chrome or Firefox? (IE is intended to desappear) or even Edge to automate :wink:

Suggestion from @AndyD worked perfectly thanks guys!

1 Like

Hi @shawnmurray
Please send a screenshot of the UiExplorer

When it loops back and runs the search for the next name on the excel sheet it fails to find the connect button, any suggestions?

@shawnmurray - Check whether the Connect Button selector is anywhere linked with the name or id of that search person.


Its not, because if the top person is already connected it will go to the second one down but on the second search it doesn’t find the button at all