Cannot create unknown type - Version incompatibility?

Hi everyone,

I have developed a robot with Studio 19.10 Enterprise Edition and I am trying to run it unattended with an Enterprise Robot also Version 19.10. The robot runs fine if started locally from my development machine.

However when started unattended from the orchestrator or from the agent (when logged in via RDP session) I always get the following error:

Cannot create unknown type ‘{}OpenBrowser’

In the project I used Version 20.4 of the packages System.Activities and UIAutomation.Activities because I need to use the new SAP activities provided in this releases. I mad sure I uploaded the packages to the orchestrator and checked if they had been loaded. I also tried copying the packages over manually.
So the packages are there definitely.

If there is a version incompatibility of package 20.4 with robot 19.10 I would understand if the robot does not work at all but why does it work locally but not unattended?

Best regards

Hi @nazraxo,

Is the unattended machine different from the development machine, if that is the case please ensure whether the required packages are downloaded to the unattended machine.
Since its orchestrator based you can locate the packages in Nuget folder of user data.

Hi @shivagowdavarad,

Unattended machine and development machine are different. I double checked and the packages are all there. They are on the orchestrator as well as in the .nuget directory of the robots unattended machine.


Did you end up resolving this issue?

Currently experiencing the same issue and we have confirmed that all the required package files are in the correct locations.

Development machine and UAT machine both running 2019.10.4. Works fine on the development machine, however receives the same error as you when we run it from Orchestrator on the UAT machine.

Cannot create unknown type ‘{}OpenBrowser’ error

I did not find a solution for our current setup, so I just upgraded the robots to 20.4.
This resolved the issue, so there seems to be some kind of upwards incompatibility which only occurs when running the process on a robot different from the development machine.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.